Author Topic: [3.5.8249 P] New random crashes & lockups - seemingly audio driver connected ?  (Read 1546 times)

alec.tron

  • Sr. Member
  • ****
  • Posts: 752
Hi,
I updated to 3.5.8249 P a few days ago, and added a new Playlist Mixer & an Auto Playlist recently, but nothing else than that changed.
MusicBee, today on ~2 hrs of use has now crashed a good 10+ times. The first 2 times with an error pop up, where it complained that the audio driver disconnected (or some such - never seen that one).
I then switched from DirectSound [which is odd that it was even set to that, as it always was set to Wasapi shared], to Wasapi shared, and the crashing/lockups continued, even harder than before seemingly [often being triggered then skipping/jumping to the next track]. So I tried to switch back again to DirectSound, to copy the error message [which was fairly long...], but now after I switched back - it now only freezes up completely as well and needs to be shut down.

The only log files I can see is:
ActivityLog.dat - which I can open, but only holds the last completely played tracks (from the looks ?)
and
ErrorLog.dat
which hasn't been written on any of the crashes seemingly. But, I found this in there, which could be, from the time stamp, from the first 2 crashes where it did show an error [and, MusicBee after shutting down the UI, still idled as a process with a static RAM  usage of around 200mb], this would be that entry:
Code
6/08/22 18:11:08 - 10.0.19044.0 - 3.5.8249.26390P - #=zEK8K$S544MPfzxzzMk3jfaj2f9Sc: Exception of type '#=zEK8K$S544MPfzxzzMk3jfaj2f9Sc' was thrown.
   at #=z0sLCoilYslbuwUcknTkiKjQ=.#=zf3ppOYAeWWsf(Boolean #=zzb_bVuU_XTTo, #=zAnQ8ENQ8h8pzxF5LEa1M9vY= #=zYBGqrYoBk2ZF, Int32 #=zqOXSqLnZrG93yKnsMg==)
   at #=z0sLCoilYslbuwUcknTkiKjQ=.#=zY2FBBn57rSXJq27Hhw==(#=z_zNqH$faUhfZU$GMEUz5ixJD36cb #=z3QGKKUM=, String #=zFqVgIcrgSV7HoXl8Sw==, #=zd1ObdBu9pkh23QftSw== #=zXqUFgLuyoJtitgRrjA==, Int32 #=z_P2mzg9RwbS$, String #=zHT2$Vko=)
   at #=ziCWWFX7vFGtBZsK9zhBIRs8GXv8e.#=zf4HUrYJd4KPB()
   at #=ziCWWFX7vFGtBZsK9zhBIRs8GXv8e.#=zjDdcyzw=()
   at #=zirzVZL2x2rZvCrp2wWF4oAw=.#=zuRskS_pQdR9K()

Since no one else seems to have gotten any new crashes seemingly, based on the bug forum, I would start with deleting the 2 newly created playlists...
Any other things I could try / look at / post here ?

Cheers.
c.

ps. I use a rme babyface pro & its' drivers - and have for the last years without any issue...

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34258
The only changes have been with some tweaks to rate handling for ASIO output and the latest bass.dll version.
You could try replacing bass.dll with the version from the older release but otherwise I wont be able to help with this
Last Edit: August 07, 2022, 12:08:37 AM by Steven

alec.tron

  • Sr. Member
  • ****
  • Posts: 752
Hi,
fair enough. Thanks for the feedback & idea. I'll try around with bass.dll versions, the recently created playlists, or go back to a backup version of the previous portable install.

Just FYI:
After restarting the PC in question today, I now immediately got the pop up error again (as I shut it down yesterday set to DirectSound):


As well as the error UI popup and readout when switching player back to Wasapi (shared)
Code
MusicBee v3.5.8249.26390P  (Win10.0), 7 Aug 2022 12:43:

#=zEK8K$S544MPfzxzzMk3jfaj2f9Sc: Exception of type '#=zEK8K$S544MPfzxzzMk3jfaj2f9Sc' was thrown.
   at #=z0sLCoilYslbuwUcknTkiKjQ=.#=zf3ppOYAeWWsf(Boolean #=zzb_bVuU_XTTo, #=zAnQ8ENQ8h8pzxF5LEa1M9vY= #=zYBGqrYoBk2ZF, Int32 #=zqOXSqLnZrG93yKnsMg==)
   at #=z0sLCoilYslbuwUcknTkiKjQ=.#=zY2FBBn57rSXJq27Hhw==(#=z_zNqH$faUhfZU$GMEUz5ixJD36cb #=z3QGKKUM=, String #=zFqVgIcrgSV7HoXl8Sw==, #=zd1ObdBu9pkh23QftSw== #=zXqUFgLuyoJtitgRrjA==, Int32 #=z_P2mzg9RwbS$, String #=zHT2$Vko=)
   at #=ziCWWFX7vFGtBZsK9zhBIRs8GXv8e.#=zf4HUrYJd4KPB()
   at #=ziCWWFX7vFGtBZsK9zhBIRs8GXv8e.#=zjDdcyzw=()
   at #=zirzVZL2x2rZvCrp2wWF4oAw=.#=zuRskS_pQdR9K()

ALso, after shutting down MB after the above error, the MB UI dissapears, but the process seems to get stuck on shutdown infinitely:

And needs to be killed by hand.

Just thought I'd mention this, as it appeared all of a sudden, and MB locking up 10+ times in an hour is a new experience, as it has been super stable for me.
Oh well.
c.

ps. same error when switchng to ASIO
Code
MusicBee v3.5.8249.26390P  (Win10.0), 7 Aug 2022 12:49:

#=zEK8K$S544MPfzxzzMk3jfaj2f9Sc: Exception of type '#=zEK8K$S544MPfzxzzMk3jfaj2f9Sc' was thrown.
   at #=z0sLCoilYslbuwUcknTkiKjQ=.#=zf3ppOYAeWWsf(Boolean #=zzb_bVuU_XTTo, #=zAnQ8ENQ8h8pzxF5LEa1M9vY= #=zYBGqrYoBk2ZF, Int32 #=zqOXSqLnZrG93yKnsMg==)
   at #=z0sLCoilYslbuwUcknTkiKjQ=.#=zY2FBBn57rSXJq27Hhw==(#=z_zNqH$faUhfZU$GMEUz5ixJD36cb #=z3QGKKUM=, String #=zFqVgIcrgSV7HoXl8Sw==, #=zd1ObdBu9pkh23QftSw== #=zXqUFgLuyoJtitgRrjA==, Int32 #=z_P2mzg9RwbS$, String #=zHT2$Vko=)
   at #=ziCWWFX7vFGtBZsK9zhBIRs8GXv8e.#=zf4HUrYJd4KPB()
   at #=ziCWWFX7vFGtBZsK9zhBIRs8GXv8e.#=zjDdcyzw=()
   at #=zirzVZL2x2rZvCrp2wWF4oAw=.#=zuRskS_pQdR9K()

pps. another oddity - a recent backup run of the current portable install (with the 3.5.8249 P version - before attempting to fix by hand whatever mugh be happening here...) it did also remove around 5k files of album art from
*\AppData\InternalCache\AlbumCovers\
Last Edit: August 07, 2022, 12:02:15 PM by alec.tron

alec.tron

  • Sr. Member
  • ****
  • Posts: 752
Hm. I removed the 2 new playlist (an autoplaylist drawing from another playlist and a PlaylistMixer - to test around how to get a dynamic playulist that only has content that is either fairly new, or hasn't been played for 6+ months ish) and all crashes are gone and it's been stable again for 2 hrs.
Again, very odd...
c.

ps. fopr transparency/documentation purposes - this is the content of the 2 playlists, retrieved from the previously archived backup (minus the absolute file paths inside them, which I replaced the original absolut filepath in by hand against a *...):

*\Library\Playlists\XX_NoExport_AutoPlaylists\Auto DJ.xautopf
Code
<?xml version="1.0" encoding="UTF-8"?>
<SmartPlaylist SaveStaticCopy="False" LiveUpdating="True" Layout="4" LayoutGroupBy="0" ShuffleMode="None" ShuffleSameArtistWeight="0.5" GroupBy="track" ConsolidateAlbums="False" MusicLibraryPath="C:\*\Library\">
  <Source Type="16">
    <SourcePath Location="C:\*\Library\Playlists\XX_NoExport_AutoPlaylists\JustListen.xautopf" />
    <Description />
    <Conditions CombineMethod="Any">
      <Condition Field="FileLastPlayed" Comparison="LessThan" Value="2/02/22" />
      <Condition Field="FileDateAdded" Comparison="Is" Value="1/06/22" />
    </Conditions>
    <Limit FilterDuplicates="False" Enabled="True" Count="100" Type="Items" SelectedBy="LeastOftenPlayed" />
    <SortBy Field="2" Order="Ascending" />
    <Fields>
      <Group Id="TrackDetail">
        <Field Code="20" Width="15" />
        <Field Code="78" Width="29" />
        <Field Code="75" Width="75" />
        <Field Code="99" Width="58" />
        <Field Code="61" Width="60" />
        <Field Code="132" Width="82" />
        <Field Code="32" Width="211" />
        <Field Code="65" Width="232" />
        <Field Code="16" Width="47" />
        <Field Code="47" Width="148" />
        <Field Code="46" Width="144" />
        <Field Code="86" Width="30" />
        <Field Code="30" Width="156" />
        <Field Code="88" Width="40" />
        <Field Code="175" Width="39" />
        <Field Code="41" Width="39" />
        <Field Code="98" Width="44" />
        <Field Code="49" Width="41" />
        <Field Code="143" Width="262" />
        <Field Code="134" Width="81" />
        <Field Code="25" Width="20" />
        <Field Code="10" Width="46" />
        <Field Code="183" Width="64" />
        <Field Code="9" Width="62" />
        <Field Code="44" Width="94" />
        <Field Code="2" Width="1087" />
        <Field Code="72" Width="779" />
        <Field Code="64" Width="83" />
        <Field Code="66" Width="62" />
        <Field Code="42" Width="63" />
        <Field Code="84" Width="62" />
        <Field Code="95" Width="81" />
        <Field Code="12" Width="110" />
        <Field Code="94" Width="69" />
      </Group>
    </Fields>
  </Source>
</SmartPlaylist>

*\Library\Playlists\XX_NoExport_AutoPlaylists\Playlist Mixer.xradiopf

this file is empty.

*\Library\Playlists\XX_NoExport_AutoPlaylists\Playlist Mixer.xradiopf_0
Code
<?xml version="1.0" encoding="UTF-8"?>
<SmartPlaylist SaveStaticCopy="False" LiveUpdating="True" Layout="0" LayoutGroupBy="0" ShuffleMode="Random" ShuffleSameArtistWeight="0.5" GroupBy="track" ConsolidateAlbums="False" MusicLibraryPath="C:\*\Library\" MinimumArtistGap="0" ShuffleEntireMix="True">
  <Source Type="16">
    <SourcePath Location="C:\*\Library\Playlists\XX_NoExport_AutoPlaylists\JustListen.xautopf" />
    <Description />
    <Conditions CombineMethod="All">
      <Condition Field="Rating" Comparison="GreaterThan" Value="30" />
    </Conditions>
    <Limit FilterDuplicates="False" Enabled="False" Count="1" Type="Items" SelectedBy="Random" />
  </Source>
</SmartPlaylist>

*\Library\Playlists\XX_NoExport_AutoPlaylists\Playlist Mixer.xradiopf_global
Code
<?xml version="1.0" encoding="UTF-8"?>
<SmartPlaylist SaveStaticCopy="False" LiveUpdating="True" Layout="4" LayoutGroupBy="0" ShuffleMode="None" ShuffleSameArtistWeight="0.5" GroupBy="track" ConsolidateAlbums="False" MusicLibraryPath="C:\*\Library\" MinimumArtistGap="0">
  <Source Type="1">
    <Description />
    <Conditions CombineMethod="All">
      <Condition Field="FileLastPlayed" Comparison="LessThan" Value="2/02/22" />
    </Conditions>
    <Limit FilterDuplicates="False" Enabled="False" Count="25" Type="Items" SelectedBy="Random" />
  </Source>
</SmartPlaylist>
Last Edit: August 07, 2022, 02:39:17 PM by alec.tron

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34258
the issue and error is related to the device locking up. The only thing i can think of is the mixture of tracks has different channel counts or sample rates

alec.tron

  • Sr. Member
  • ****
  • Posts: 752
Unfortunately for me, removing the newly added auto playlists was no long term fix.
The issue is back every day; sometimes locking up musicbee once in 2-3 hrs, sometimes (as just now) 10+ times per hour.

A few observations:
- re "mixture of tracks has different channel counts or sample rates" - this also happens when listening to a single album, so the tracks are of the same channel count & sample rate setting.
- the bass.dll I have after the last update (i.e. MusicBee_Setup_3_5_8249.exe) has a timestamp from 2021.09.08 - checking older portable updates/patches, I unfortunately can not find a recent-ish older that makes sense to go back to ( ? I found one in a portable/patched archive I still have from May2018, with a times stamp from 2017.08.26 - which feels a bit too old to go back to, especially seeing that I barely had any lockup/crashing problems with MB and the same USB drivers/soundcard [rme babyface] combination since around 2018 until a few weeks ago when I updated to 3_5_8249)
- MB seems to regenerate the wave preview on a lot of files now as well and the wave preview bar is empty for the first 1-5 seconds for many files [i.e. not like this - https://getmusicbee.com/forum/index.php?topic=37118.0 - but going from empty to populated immediately - it feels like in the course of 5 years of usage, most was cached already and I have seen this (assuming) re-caching of the wave form only on new tracks... whereas now I see it on a lot of old files as well].
- the audio driver lockups occasionally just let MB hang for a good 5 to 30 seconds, before producing the above pop up warning. On other istances this is immediate within 0-2 seconds
- on rare occasions I can hear the very first (under 0.5 seconds) of the track that MB grinds to a halt on. This could just be coincidential as very few tracks have actual sound in the first milliseconds... some do though and this is where you here that the track does get played before MB/driver lock  up.
- interestingly, when this popup & lockup occurs, and I shut down MB via UI and the process afterwards via task manager, MB then restarts at exactly the track it previously choked upon, and plays these fine

If there's any way to analyze these lockups further on my end to get a better idea what might be causing this ? I'm clutching at any straw as is...
As you @steven already said you can't help with this - no worries if that's still the case - I just thought I'd collect what I experience, in case anyone else has these issues all of a sudden as well.

Cheers.
c.
Last Edit: August 27, 2022, 07:23:22 PM by alec.tron

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34258
this is the previous bass.dll used in older MB releases
https://mega.nz/file/MgU2DA4B#qiM0PBETZ_LA5CssBW7O08YbJ5SyugzNx_oA_grR6Ow
and bassmix.dll
https://mega.nz/file/0o8GALLa#tVaDWGLfMhAyFsf8zXr8Hey7d08FFpsxJOFIWPIe9T4

however one forum member reported a similar issue as you when using this version of bass.dll, but then the problem just went away one day. Perhaps an audio driver update. Also try whitelisting MB in your security software in case its doing something funcky
Last Edit: August 28, 2022, 12:40:56 AM by Steven


alec.tron

  • Sr. Member
  • ****
  • Posts: 752
Thanks you two - much appreciated!
Trying the above .dlls now. Windows thereafter if the lockups continue... (fingers crossed they don't)
Churs.
c.

alec.tron

  • Sr. Member
  • ****
  • Posts: 752
After switching to the above older version from Steven I haven't had a single crash/lockup - but I only had 2 evenings of semi short rounds recently, so will wait and see.
Fingers crossed the next/new version of bass (i.e. https://getmusicbee.com/forum/index.php?topic=37146.0 ) fixes the issues as well I am experiencing...
Churs.
c.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34258

Darthagnon

  • Newbie
  • *
  • Posts: 12
Quote
ALso, after shutting down MB after the above error, the MB UI dissapears, but the process seems to get stuck on shutdown infinitely:
And needs to be killed by hand.

I've had the same problem with MB GUI crashing and leaving orphaned processes for a long time. I thought it was GPU switching-related, wondering now if it might be sound drivers. I'm not seeing anything recent in my error log, though. I'll post it when it next happens.