Author Topic: Merge Fields in Album Cover View  (Read 831 times)

clatix

  • Jr. Member
  • **
  • Posts: 24
I am using Musicbee version 3.5.8150 on Windows 11. I have a customer view derived from the Album Cover with the following Fields Displayed: Album Artist; Year; Album; .Ext. I selected the Merge Fields option (so long text wraps to the next line). Well only the contents of the first Field, Album Artist, is wraped and goes to the next line. The other fields are instead truncated.


hiccup

  • Sr. Member
  • ****
  • Posts: 7937
Since this is the Bug Reports board:  What do you believe the software bug to be here exactly?

There are four lines available for fields below the artwork.
(five if you update with the latest 3.5 patch)

Are you expecting the number of lines to increase (endlessly?) depending on how long the text that they contain is?

clatix

  • Jr. Member
  • **
  • Posts: 24
Thank you hiccup for your replay.
Referring to the image shown in my post, I would expect that the Album content was extended in the fourth line together with the content of .Ext.
The two fields  Year and .Ext are used by me precisely to allow this wraping.

hiccup

  • Sr. Member
  • ****
  • Posts: 7937
That seems a request, and certainly not a software bug?

Something for the wishlist board perhaps?
(I would vote it down b.t.w., since it would move the contents of lower lines out of sight in many cases)

clatix

  • Jr. Member
  • **
  • Posts: 24
Thanks hiccup.
I thought the Merge Fields option served just to make my request. But I certainly interpreted badly.

hiccup

  • Sr. Member
  • ****
  • Posts: 7937
Ah yes, I can understand that the word 'merge' does indeed suggest that.
Still, it would be best to create a wishlist topic for it and see what others think.

clatix

  • Jr. Member
  • **
  • Posts: 24
Thanks Hiccup.
If you see the third album of my example shown above, the Merge took place between the first and second line with the contents of the Album Artist and Year.

clatix

  • Jr. Member
  • **
  • Posts: 24
Solved!
Thanks to the indication of hiccup (patch with fifth line) I added an empty line to the Fields Displayed and the result is the one I expected.
Thank you very much, hiccup.