Author Topic: Sorting by artist alphabetically, some artists' albums are randomly mixed togeth  (Read 168 times)

Nephraxis

  • Newbie
  • *
  • Posts: 3
Right now, I'm able to sort my library by artist alphabetically, but an artist's songs will sometimes be scrambled so two or more albums are all mixed together in the sort order instead of showing all of the songs in one album and then all of the songs in the next album. This only happens for some of the artists in my library. Is there some sort of property or setting that I need to set that I'm setting improperly?

Zak

  • Member
  • Hero Member
  • *****
  • Posts: 2182
There could be lots of reasons.
You'll have to post a screenshot of what you're seeing for someone to work out why MusicBee is showing tracks in the order it is.
Preferably also include the settings that you think aren't working correctly.
Bee excellent to each other...

Nephraxis

  • Newbie
  • *
  • Posts: 3
Here is a screenshot of what I'm talking about

As you can see, the artists are sorted alphabetically, but if you look at the Alien Ant Farm songs the two albums are all mixed together. Alice in Chains is all together, but I realized that the ones that appear to be in order may be the ones that only have one album to begin with.

I'm not familiar with MusicBee, so I'm not sure what settings are relevant here. What I'm trying to do is sort the track list by artist, and then order the complete albums alphabetically within each artist's section. Is that possible?

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7905
In the view you're using, you can sort by two or more columns by selecting the primary sort first, then holding down the control key and clicking the header of the second column.

In your case sort by Artist first and then Album.
Download the latest MusicBee v3.4 patch from here.
Download the latest MusicBee v3.5 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

Zak

  • Member
  • Hero Member
  • *****
  • Posts: 2182
You can also click on the Tracks heading in the top-left corner of the track list, and select Sort By > Album Artist / Album.
In that same menu is an option to Define Custom Sorting if you want to sort by a selection of columns that doesn't appear on the list.
Bee excellent to each other...

Nephraxis

  • Newbie
  • *
  • Posts: 3
I tried clicking the columns while pressing CTRL, but that didn't just sorted by the second column. Sorting by Album Artist/Album had the desired effect, though. Thanks!

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7905
I tried clicking the columns while pressing CTRL, but that didn't just sorted by the second column.
Just to be clear, left-click the header of the first column, THEN control-left-click the second (and/or more.)
Download the latest MusicBee v3.4 patch from here.
Download the latest MusicBee v3.5 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here