Author Topic: Year field stops being directly editable in Playlist view.  (Read 128 times)

Beezmann

  • Newbie
  • *
  • Posts: 13
The "Year (yyyy)" field stops being directly editable in the Playlist view.

Severity: very low.

Steps to recreate:
1) create a playlist
2) try editing any "Year (yyyy)" field value (at least non-empty one) by either clicking on the value twice or clicking it once and pressing F2. It won't become editable like it usually does.

The reasons why it's likely a bug:
1) The Year field is perfectly editable in other views like Music or Folders.
2) Other editable fields are still editable in the Playlist view, at least the ones I use.
(From what I use, only Title, Artist, and Album are always editable. Other, less common fields may be affected by the same issue as well.)

Tested in 3.5b (3.4.8033 P) and freshly installed 3.4.8033. My apologies if this has already been reported–I haven't found it in my search.

P.S. If you ever decide to address this, please consider making currently uneditable Track Gain and Album Gain fields editable as well while you're at it.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7725
Pretty sure this is not a bug as it's working fine for me both in the main collection and in a playlist.
Have you enabled Preferences > Tags (2) > tag handling > enable direct editing of tags in the main panel?
Download the latest MusicBee v3.4 patch from here.
Download the latest MusicBee v3.5 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

Beezmann

  • Newbie
  • *
  • Posts: 13
Pretty sure this is not a bug as it's working fine for me both in the main collection and in a playlist.
Have you enabled Preferences > Tags (2) > tag handling > enable direct editing of tags in the main panel?

Thanks for the quick reply and test. I knew that it might have been an issue with my skin, plugins, and so on, so I downloaded the latest version from the website and ran in through a sandbox before posting. After your "this is weird!" post, I did some additional digging and realized the source of the problem. There are two separate fields, "Year (xxxx)" and "Year". You most likely tested the Year one, since I just checked and it's editable everywhere. I was using using Year in my regular views and Year (xxxx) in the playlist view, and since the fild was sized too small to see the "(xxxx)" part of its description, I didn't realize that I was using two different fields...

Anyway, it appears that "Year (xxxx)" isn't editable at all, most likely by design. I'd still prefer it to be editable since I like to just use years and disregard the days and months, but that's obviously not true for everyone and the editing was likely disabled to prevent accidents. The solution for people like me is to change the non-editable field to the editable one, which I just did.

Thanks again for helping me figure it out as it was driving me nuts. You can just lock the thread and sorry about the confusion.