Author Topic: Make "Link to the Original Picture File" the default option when choosing art  (Read 3150 times)

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8161
Strange, if I add artwork as explained in the previous post, I see the following... Isn't this what you're after?
I'm not sure if you're addressing this to me, but when I drill to, or paste, a new cover into that screen, "link to an organized copy of the picture" is pre-ticked.
The issue I'm reporting is that after saving the artwork (and any other updated tags) and then hovering over the artwork, it only shows "embedded." It is -not- showing the path to the organized copy of the artwork as it had in the past. See my screenshots in Reply # 12.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33461
if i understand the issue correctly, just untick all the options in Preferences/Tags(1)/default location for added pictures
using the latest v3.5 patch version
https://getmusicbee.com/patches/MusicBee35_Patched.zip

if that doesnt address the issue, how exactly are the pictures being added?

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8161
if that doesnt address the issue, how exactly are the pictures being added?
The issue seems to be resolved with a quick test of one album with 3.5.8302 P.. Now in addition to "embed the picture..." being ticked, so is "link the picture..." and "like to an organized copy..." are also ticked.

For clarification, I add album artwork in one of three ways, and just test all three.
- From the Tag Editor (Tags) > paste the artwork and click save.
- From the Tag Editor (Tags) > choose picture.
- From the Tag Editor (Tags) > drag picture from file on desktop or in an existing directory.

Thanks Steven.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33461
sorry phred for not making it clear - i was responding to the OP. I didnt change anything regards your issue (and dont think anything has been changed for a long time)

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8161
sorry phred for not making it clear - i was responding to the OP. I didnt change anything regards your issue (and dont think anything has been changed for a long time)
Not a problem, Steven. But I do find it odd that the desired (previous) behavior has returned with this latest patch. I ran a couple of more tests today and there are no issues.

Even though you claim to have done nothing my reported issue, I thank you.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

Versiris

  • Newbie
  • *
  • Posts: 9
I think the reason that wasn't asking me every time was because "confirm picture storage options when adding artwork" was turned off.

That said, if I ask it to remember my choice by default and select "link to the source picture", it resets every time I close and open MusicBee, as shown here:


Any idea why it's resetting my settings? None of my other settings get reset.