Author Topic: Encoding parameters for ripping to OggVorbis  (Read 320 times)

botanicalbryan

  • Newbie
  • *
  • Posts: 1
I have been using MusicBee for a while and ripping CDs to OggVorbis format with no problems. However recently I started to find that the tracks would not encode, so I explored the codec and installed a new version of oggenc2.exe, but this did not help. I clicked 'Reset' for the encoder settings and this now allowed me to encode the files, but did not create any metadata (track number, artist name, etc). So I have been playing with the switches (as in oggenc_help.txt) but find when I add anything the files will not encode.

What I have typed in for the high quality parameters are: -q 5 -N -t -a -t -l -o [outputfile]. Basically, I don't really know what I am doing and would appreciate any guidance.

Zak

  • Member
  • Hero Member
  • *****
  • Posts: 2199
Comparing your parameters to the defaults:

Code
-q 5 - -o [outputfile]
That hyphen on its own before the output parameter is what tells the OGG encoder to read the raw data passed to it from the CD encoder as it rips each track.
You appear to have removed that, perhaps thinking it was superfluous.

For the metadata tags, you don't need to include those parameters at all. They are only relevant when running the encoder from a command line (see below).
I just ripped two tracks fine using both the older oggenc and the updated oggenc2 with MusicBee's default parameters and both worked fine, so whatever problem you were having in the first place that made you start editing the parameters, it wasn't caused by the encoder.

(If you were to encode tracks from the command line the metadata tags also need the value provided for them to work. Including -t on its own will cause an error. You would need to specify -t "Track title".)
Bee excellent to each other...