Author Topic: How to retrieve good quality genre tags using Picard  (Read 25861 times)


hiccup

  • Sr. Member
  • ****
  • Posts: 7852
Updated the virtual tag to display genres in rows in the track details panel.
(as described in post #2)

- The previous version failed in displaying subsequent genres if a preceding genre contained certain non-standard characters.
- And it now uses · (middle dot) as a separator instead of a comma. (looks nicer to me)



also:
Guess the song?
Last Edit: January 14, 2023, 02:47:34 PM by hiccup

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9340
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here


phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9340
Very nice, and close. But I don't hear any Hát tuồng in it?
Then you didn't listen all the way through. It's the seventh verse and chorus.  :-)
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

hiccup

  • Sr. Member
  • ****
  • Posts: 7852
Ah yes, between 1:54 and 1:55
Not sure how I could have missed that.

voodoopunk

  • Jr. Member
  • **
  • Posts: 53
Hi Hiccup,

Regarding your update in post 2 for the virtual tag to display the genres, I've had bash at using it but it seems if there's only a single genre then a bunch of semi-colons are displayed. I'm assuming this isn't by design?

hiccup

  • Sr. Member
  • ****
  • Posts: 7852
...but it seems if there's only a single genre then a bunch of semi-colons are displayed. I'm assuming this isn't by design?
Can you post a screenshot of that?

voodoopunk

  • Jr. Member
  • **
  • Posts: 53
Here, take a look. I will be adding genres to this as just Hardcore isn't correct but it shows the semi-colons. Not that it should make any difference but I didn't use a virtual tag, just pasted your code a track information field.


hiccup

  • Sr. Member
  • ****
  • Posts: 7852
Not that it should make any difference but I didn't use a virtual tag, just pasted your code a track information field.
That's o.k. and how I use it too. No need to sacrifice a virtual tag on this.

At the moment I can't explain why this is happening for you. (it's working fine here, also for single genres)
- what MB version are you on exactly?
- does it only happen when there is only 1 genre?
- could you post a screenshot of the settings panel?
Last Edit: January 21, 2023, 01:59:28 PM by hiccup

voodoopunk

  • Jr. Member
  • **
  • Posts: 53
Just realised, I hadn't ticked the split mutli-tagged box. My fault.

hiccup

  • Sr. Member
  • ****
  • Posts: 7852
Yes, that's pretty essential for this to work ;-)

And it seems you are not using Picard to populate your genres?
I'm getting more than one for that release:


voodoopunk

  • Jr. Member
  • **
  • Posts: 53
I'd have sworn blind I'd ticked it. You even explain about the semi-colons in that second post.

No, I'm not using Picard for my genres, I'm using RYM and inputting manually. I haven't got around to that release yet is all.


Mr. Trev

  • Sr. Member
  • ****
  • Posts: 459
A quick question about using your track info virtual tag again…
I swapped to the modded version (different separator), changed it 2 genre per line. The genres gets truncated.
I was wondering if there is a way to use word wrap or if it's just something that'll come down to panel size and luck of the draw

and one minor critique. When the tag splits the lines, it leaves the · behind. If I remember my typography, a line shouldn't end with a · (examples in your earlier screenshots)

sorry to pick nits (and I admit, I have no idea if/how that can be fixed)
Last Edit: January 30, 2023, 01:00:01 AM by Mr. Trev