Author Topic: Backup Library Halted by Hidden System Attributed Folder.JPG files  (Read 607 times)

Jaslan

  • Jr. Member
  • **
  • Posts: 21
I am posting this as a question in case others have this issue I had and maybe someone with a better understanding of it can even help me understand it better.
While migrating to Musicbee and organizing, retagging, and cleaning up my library, I would occasionally use the Backup function just in case I screwed up and lost some work...
I am coming from WMP and the problem was that the FIRST backup (to a new location... so all files copied fresh) would work fine.  Then, after doing some more editing, if I tried another backup, it would be halted because MB was denied access to one of the Folder.JPG files (I think it was always one of the albums I had changed the artwork for).  BUT, when I went to the location, the Folder.JPG file was hidden EVEN with view hidden files enabled.  I came to the conclusion (but not really certain) that those files were also tagged as system files so could not be viewed or have their properties (such as read-only) modified.  When I looked at the root music folder, it would have the "dash" in the read only box (meaning SOME files in there are read only but not all (which would be a check mark).  Unchecking the read only for the whole folder never seemed to work.  Again, I think because the folder files are attributed as hidden system files....

The solution I came up with was to update ALL the Album art with new pictures (the WMP ones were crappy resolution anyway) and have MB organize the library to a new location so that it could write it's own Folder.JPG files.  I had a few more times where I missed updating the artwork (or maybe if there wasn't already a Folder.JPG file created by MB then WMP would write one with the read only properties?).  Anyway, I stopped opening WMP and got all my art updated in MB with normal (not hidden, system) Folder.JPG files and haven't had the permission problem during backup since.  BUT, if I do get it again, my solution will be to delete the offending album folder IN THE BACKUP location.  This will delete the associated Folder.JPG file and the backup will rewrite all the deleted files anyway, including the new folder.jpg file.

This had me really frustrated for about half a day and I hope this information helps someone.  If anyone really understands what was happening and want's to explain or provide a less "hacked" solution I am grateful.
I am using Windows 11, latest update and latest MB version.

hiccup

  • Hero Member
  • *****
  • Posts: 5949
WMP will probably be guilty of creating these hidden folder.jpg files and setting them to system files.
You could try this solution to fix that for all files in your music folder(s):
(best to first try this on a test folder containing some copies of your files?)

https://www.blisshq.com/music-library-management-blog/2012/02/01/removing-windows-folder-jpg-system/

edit:
I recall having had similar issues not only with hidden jpg's named 'folder.jpg', but also with jpg's named something like:
'AlbumArt_{ADED2DE7-25F2-4CF5-8A29-A3142DE92004}_Small.jpg'

To catch those too, in the command prompt you could use:
Code
attrib -s -h *.jpg /s
Last Edit: December 28, 2021, 07:19:04 AM by hiccup

Jaslan

  • Jr. Member
  • **
  • Posts: 21
Thanks for the reply and help. 
I actually found that article when I was trying to sort out the problem.  One of the problems I had was the backup was on an external USB drive and the DOS prompts wouldn't seem to let me change the drive to the E: drive.  I actually used to be pretty handy in MS DOS back in those days but couldn't get it to work.
I tried
CD E:\
CD E:  (which would echo back E:\ but the prompt was still showing me on the C drive in the users folder)
even tried CD.. to see if I could back out far enough, etc.

I did find some mentions that all of the hidden folder files may be going away or no longer in use with Windows 11 (but pre-existing ones are still there?), which had some people upset because they like the contents preview thumbnails for the folders.  Well, no worries because we know it will probably change again.

hiccup

  • Hero Member
  • *****
  • Posts: 5949
One of the problems I had was the backup was on an external USB drive and the DOS prompts wouldn't seem to let me change the drive to the E: drive.
I am guessing it should be possible to solve that drive letter issue. But it would need some further investigation what causes this for you.
(which is probably something for 'Beyond MusicBee' ;-)

Another thought: If you would also be satisfied with simply deleting all hidden jpg's, instead of unhiding them, there are search tools that can help with that.
I myself use FileLocator Pro, and it allows to search for specific file types with specific file attributes. (hidden, read only, etc.)
Just search for *.jpg that have the 'hidden' attribute, select all, press [Del].
Problem solved…

Jaslan

  • Jr. Member
  • **
  • Posts: 21
My guess is that the E: drive has something to do with the way Windows handles and names removable drives since the E: drive could change alot but your are right, that discussion is beyond the scope of this thread.  
I essentially handled it in the way you suggest (by deleting all of them) by starting a fresh back folder which has no folder.jpg files yet.  I uninstalled WMP so it can't create more (although I read one article that Windows may do this on its own without WMP even being opened but this may be going away with Windows 11 not using folder.jpg files anymore?).  I also set Musicbee to save all the art as folder.jpg so there is already one in every folder.  Musicbee does warn that these could be overwritten by Windows or WMP, in which case I have just deleted the folder where I want the backup to save and let Musicbee rewrite all the files in that folder during the backup.  Again, I uninstalled WMP so hopefully won't get anymore created...

But, anyway, I think you are right that the easiest way is to just delete the offending folder so musicbee can do it's job during the backup.