Author Topic: Change Album Length from mmm:ss Format to hh:mm:ss Format  (Read 1712 times)

doobydiper

  • Newbie
  • *
  • Posts: 17
Hello all!
I found this post from 2017 that describes what I'm looking for perfectly. Basically, my library is full of audiobooks that are hours long and their track lengths are unfortunately formatted as mmm:ss, (so a 2 hour 10 minute 30 second track becomes 130:30). I would rather have it formatted as hh:mm:ss (2:10:30), like it at the bottom of the screen when you play a track. In the post I linked, Steven replied in April of 2020 that this would be an added feature in ver. 3.4, but I haven't seen any instructions on how to make this change. I was wondering if it was in fact added and if anyone knows how to access and configure this option. Thanks for any help!
*edited for spelling
Last Edit: December 28, 2021, 12:48:47 AM by doobydiper

doobydiper

  • Newbie
  • *
  • Posts: 17
It's been quite a while since I had made the original post, and I had long ago settled with what I have. However, with new updates and perhaps new information, I'm hoping that someone might know if this is possible now? Thank you! :0)

tjinc

  • Sr. Member
  • ****
  • Posts: 383
I think that this is already the default behaviour, using MusicBee 3.58657 P.
Is this what you are wanting:



I don't think there are any settings for this. What MusicBee version are you using?

doobydiper

  • Newbie
  • *
  • Posts: 17
Hmmm, I'm on the most recent version on my desktop, though my laptop has an older version, and they both have the issue. When I start to play an album, the time at the bottom is how I want it and isn't the issue, but the album 'preview' is only listed at mmmm:ss. If you have any other hours-long tracks in your collection, are they also in the hh:mm:ss format? You didn't fiddle with anything prior?
Screenshots are from Version 3.5.8447

Last Edit: September 22, 2023, 12:21:04 PM by doobydiper

tjinc

  • Sr. Member
  • ****
  • Posts: 383
Ah, ok. It looks like the time is displayed differently in different views:

My image shows the 'Albums and Tracks' view with a time of 1:07:03.
If I change to the 'Tracks' view it shows 1:07:03
If I change to the 'Album Covers' or 'Artists' view it shows 67:03 (as per your image).

I guess this is a bug (or at least an inconsistency) so you could post on the bugs board.

doobydiper

  • Newbie
  • *
  • Posts: 17
My 'Album and Tracks' view keeps the same issue as the other views, but the 'track' view has the hh:mm:ss format. Very odd!
Album and Tracks Screenshot

Tracks Screenshot

I typically view my albums in the 'playlists' category, as they're all audiobooks and I like seeing their covers :0)
Though not a solution, the insight you provided is very appreciated! Perhaps it is simply an oversight somewhere?

tjinc

  • Sr. Member
  • ****
  • Posts: 383
'Album and Tracks' view:
When set to Compact Grid shows time in mmm:ss
When set to Detailed List shows time in hh:mm:ss

and yes, I would say that this is an oversight.

Edit:
I have posted a bug report.
Last Edit: September 22, 2023, 01:18:22 PM by tjinc

tjinc

  • Sr. Member
  • ****
  • Posts: 383
doobydiper - Have you spotted this patch?
I think this will give you what you are wanting.