Author Topic: 4.0 and 5.0 multichannel music is not routing to the correct channels  (Read 1811 times)

nateybee

  • Newbie
  • *
  • Posts: 5
I've got quite a few quadrophonic recordings, and I've noticed that I am not able to get the channels to play back properly for 4.0 and 5.0 configurations. I have no issue playing back 5.1 and 7.1 in Musicbee.

For example: surround right speaker would remain silent, while hearing little thumps from my subwoofer. It seems like it's transposing the right surround to the LFE channel, even though there shouldn't even be an LFE channel. No matter the source, I am able to replicate this. I am also only able to replicate it with musicbee. VLC, MPC-BE, foobar, all route the channels correctly, very plug n play.

I have this dumb workaround where I'll create an LFE track in audacity, and suddenly all the channels are being routed properly.

Anyone else experiencing this?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32300
what output mode are you using? eg. ASIO, WASAPI (shared), WASAPI (exclusive)

nateybee

  • Newbie
  • *
  • Posts: 5
Good afternoon! I appreciate the response.

Kinda speechless right now, I've been dealing with this issue for months. I try again today to replicate the glitch after updating audio drivers, and I simply can't get it to route incorrectly anymore with 5.0 channels.

At this point, I wish I knew what fixed it. I really am curious if it was just the nvidia audio drivers being updated recently. Thanks, though.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7056
Good afternoon! I appreciate the response.
But you didn't answer Steven's question. Which might be helpful in order to track down what was happening.
Download the latest MusicBee v3.4 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

nateybee

  • Newbie
  • *
  • Posts: 5
Output was always WASAPI (shared). I swapped to WASAPI (exclusive) and that's when I realized I wasn't able to replicate the channels being routed incorrectly. Thinking that my problem was solved with switching to exclusive, I swapped BACK to shared.

Yeah. I can't replicate this months long issue anymore and that's why I didn't think to reply back answering the specific question. I'm sorry. like, I don't know what else to say.

nateybee

  • Newbie
  • *
  • Posts: 5
Just prefacing this by saying I'm a novice, and I really want to learn.

Earlier today I was playing some 7.1 channel music, and found that I actually wasn't getting any sound output from my surround left/right speakers. The rears and everything else played back fine.

Going back into the player settings, I am still in WASAPI shared. BUT, I did see that the "upmix stereo to 5.1" option was checked. I disabled upmixing, and I get full 7.1 reproduction again for those files.

Going BACK to the 5.0 channel music, I realized that the channels are being mapped incorrectly again. If I knew this setting was affecting anything, I would've definitely looked to see if anyone else reported this as a bug. So I apologize again if I'm just restating an already known issue.

nateybee

  • Newbie
  • *
  • Posts: 5
I believe I figured it out.

1. with the upmix stereo to 5.1, this DOES mess up routing for 8 channel and 4/5 channel stuff as well. It appears to be trying to up/downmix these to 5.1

2. with the upmix option DISABLED, with WASAPI shared ON I get the misrouted channels.

3. upmix still disabled, with WASAPI (exclusive) ON, I am able to get accurate channel routing.

Whether this is truly a bug in the sense that it effects OTHER quad heads, or just a weird quirk of my sound system.. I'll leave the determination up to you. Thank you guys for getting me on the right path.

sveakul

  • Hero Member
  • *****
  • Posts: 1779
3. upmix still disabled, with WASAPI (exclusive) ON, I am able to get accurate channel routing.

Glad you were able to sort this.  Wasapi exclusive sends audio as-is from the original file to your audio device, "shared" ends up in the Windows Mixer first which does who-knows-what-all to it.