Author Topic: Noto Sans font not working properly in MusicBee  (Read 3431 times)

DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
Hey everyone.
I just installed the Noto Sans font because I want to use it in MusicBee but most of the text uses the Arial font for some reason. Is there any way to fix it? I've already reinstalled the font and restarted my PC. I have the same problem with Noto Serif btw.
Here's a screenshot of my MusicBee, every text that uses the correct font is marked red.
https://imgur.com/d33SuFt

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9388
If the new font displays correctly in one part of MB then it should work in all.
Fonts need to be set in -many- places within MB's settings. Have you changed them all to the new one?
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
If the new font displays correctly in one part of MB then it should work in all.
Fonts need to be set in -many- places within MB's settings. Have you changed them all to the new one?
Yep, I've changed the font everywhere.

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9388
Yep, I've changed the font everywhere.
I'm still not convinced.
Please post a screenshot of your track details configuration.
Click the word 'tracks' in the upper left of the window > customize panel
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
Yep, I've changed the font everywhere.
I'm still not convinced.
Please post a screenshot of your track details configuration.
Click the word 'tracks' in the upper left of the window > customize panel
Sure, here are some screenshots of my font settings
https://imgur.com/a/rKijKBV

hiccup

  • Sr. Member
  • ****
  • Posts: 7937
You selected some 'blk' version of Noto Sans.
What happens if you use a regular type?

I have Noto Sans 1.04 and it works flawlessly:
(and it shows size 9.75 instead of your 9.749999?)


DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
You selected some 'blk' version of Noto Sans.
What happens if you use a regular type?

I have Noto Sans 1.04 and it works flawlessly:
(and it shows size 9.75 instead of your 9.749999?)


All versions aren't working for me.

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9388
Sure, here are some screenshots of my font settings
That's not the screenshot I asked for.
It looks to me that you have not changed the font everywhere.

Read what I wrote and post the requested screenshot.
Click the word 'tracks' in the upper left of the window > customize panel
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

hiccup

  • Sr. Member
  • ****
  • Posts: 7937
All versions aren't working for me.

Specify 'all versions'.
I mentioned 1.04 regular works perfectly here.

DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
Sure, here are some screenshots of my font settings
That's not the screenshot I asked for.
It looks to me that you have not changed the font everywhere.

Read what I wrote and post the requested screenshot.
Click the word 'tracks' in the upper left of the window > customize panel
I did that, it's the 4th screenshot. And all fonts work fine except Noto Sans and Noto Serif.

DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
All versions aren't working for me.

Specify 'all versions'.
I mentioned 1.04 regular works perfectly here.
By all versions I meant Noto Sans Regular, Bold, Black etc.
Did you download the font from https://www.google.com/get/noto/ ?

hiccup

  • Sr. Member
  • ****
  • Posts: 7937
I don't recall where I downloaded it, but what is—or may be—important is the font version, that I mentioned twice now.

And what is your MusicBee version?
And, portable/install/store?

DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
I don't recall where I downloaded it, but what is—or may be—important is the font version, that I mentioned twice now.

And what is your MusicBee version?
And, portable/install/store?
I have Noto Sans 2.000 according to the metadata.
My MusicBee version is 3.4.7866 (Not portable). The dev made it for me because some track durations were wrong.

hiccup

  • Sr. Member
  • ****
  • Posts: 7937
I have Noto Sans 2.000 according to the metadata.
My MusicBee version is 3.4.7866 (Not portable). The dev made it for me because some track durations were wrong.

Strange, if I use the download link you provided, I get 1.04 (again)
I'm gonna leave it at this.

B.t.w. you can safely update your MusicBee version too.
The duration fix is not only for that specific version.

DJ-Alpha

  • Jr. Member
  • **
  • Posts: 24
I have Noto Sans 2.000 according to the metadata.
My MusicBee version is 3.4.7866 (Not portable). The dev made it for me because some track durations were wrong.

Strange, if I use the download link you provided, I get 1.04 (again)
I'm gonna leave it at this.

B.t.w. you can safely update your MusicBee version too.
The duration fix is not only for that specific version.
Okay so I downloaded the font from https://fonts.google.com/specimen/Noto+Sans#standard-styles now, it's 1.04 and works just fine. Weird.