Author Topic: Tags seen in Mp3Tag and iTunes not showing in MB and unable to save Tag Changes  (Read 1778 times)

naifyboy

  • Newbie
  • *
  • Posts: 11
I have quite a few tracks where the Artist and Album Artist tags can be seen in Mp3Tag, iTunes and also the Details property in Windows Explorer, however, the are not showing in MB.

Interestingly, when I try and manually edit the tag detail and click Save in MB, the detail is not saved.

I have compared permissions for the files with others that work fine and also the parent folders. The permissions are exactly the same and I have also reapplied in re-inherited the same permissions a few times to try fix it. I have also checked they are not read-only.

Any ideas?

Image of MB playlist with missing tags

Image of Mp3Tag showing tags

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32741
if you hover the mouse over the ! icon, what does it say?
If it says the file is corrupted, can you send me a link to a zip of a couple of them

naifyboy

  • Newbie
  • *
  • Posts: 11
Hi Steven
Doesn't say corrupt, just says no tags. See comparing screenshots of MP3Tag, Windows File Explorer and MB for the example.
I have a tonne of these showing OK in MP3Tag and Windows 10 but not MB.
Out of interest, does the MB database need to sync with meta data on the files or is it a live call that should show any tags that are added in MP3Tag immediately?

Shown in MB

Shown in MP3Tag

Shown in Windows 10 File Explorer

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32741

sveakul

  • Hero Member
  • *****
  • Posts: 1892
Out of interest, does the MB database need to sync with meta data on the files or is it a live call that should show any tags that are added in MP3Tag immediately?
Just addressing this part, if you add/change any tags on library files using an external tagger like Mp3tag instead via MusicBee's own tag editor, you must rescan the files in MusicBee for it to pick up the changes (right-click, SendTo->File Rescan, or for a whole library, Tools->Advanced->Rescan All Files).

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10617
Just addressing this part, if you add/change any tags on library files using an external tagger like Mp3tag instead via MusicBee's own tag editor, you must rescan the files in MusicBee for it to pick up the changes (right-click, SendTo->File Rescan, or for a whole library, Tools->Advanced->Rescan All Files).

If you have the folder they're in set to Continuously Monitor, the changes should get picked up right away. But if for some reason they're not, rescanning will definitely do the trick.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

naifyboy

  • Newbie
  • *
  • Posts: 11
Been looking at this for a few days now.
I have forced a full rescan of all files beofre and after editing the tags in both MP3Tag and windows Explorer;
Uninstalled and reinstalled MB a couple of times;
Removed and re-added the library, the forced another rescan;
Edited the tags in MP3Tag, closed MP3Tag then removed and re-added the library in MB.

I still get the same result and it's not always the same files.
The one common thing is when I look at the file properties in windows the tags are there and in the MP3Tag they are there, but not seen in MB.

Screen shots below:

Shown in MB and Windows Explorer
Shown in MP3Tag

Here's a link to the file....
https://www.dropbox.com/sh/fzx4kd7n213o4zz/AACmqjNh4846LOBaxW0b02hWa?dl=0

hiccup

  • Hero Member
  • *****
  • Posts: 5874
A wild guess:

I notice you have (lots of) \\ backslashes in the comment fields of those tracks.
What happens if you remove those?

naifyboy

  • Newbie
  • *
  • Posts: 11
All my files have \\ in the comments. It from when I stored the library in iTunes to give me a quick reference to the path.
I would expect them all to not work if that was the issue.

hiccup

  • Hero Member
  • *****
  • Posts: 5874
I would expect them all to not work if that was the issue.
So you are not going to do a test what happens if you remove those backslashes?

naifyboy

  • Newbie
  • *
  • Posts: 11
I would but it's a big job to remove 20,000 comment tags and then be sure I can restore them successfully.


hiccup

  • Hero Member
  • *****
  • Posts: 5874
I would but it's a big job to remove 20,000 comment tags and then be sure I can restore them successfully.
Make a copy of one of the problematic files, change the filename, import it into mb, remove all comment fields it contains. (using Tag Inspector)
That shouldn't be so difficult.

naifyboy

  • Newbie
  • *
  • Posts: 11
I think you missed the part when I said it was random.
If i remove the library and re-add it a few others will have the same problem but the original ones won't.
As Steven requested I have provided sample files. Hopefully he'll take a look as this is very random.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32741
Using the file you provided I see no issues whatsoever - all tags are loaded as shown in your mp3 tag screenshot.
You dont say which MB version you are using so make sure its the latest from the downloads page.
If you loaded your library direct from iTunes its possible the tags are incorrectly loaded because of whats recorded in the iTunes database.
If you select and right click/ send to/ rescan files the tags should be loaded direct from the file

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3752
  • MB Version: 3.5.8155 P
Artist & Album Artist show for me in all 3 test files as well.
However, MP3val does report the Madonna track as having an error.
MusicBee and my library - Making bee-utiful music together