Author Topic: How to split groups vertically? (track grouping/sorting in main panel)  (Read 2035 times)

heroclix

  • Newbie
  • *
  • Posts: 11
Hello,

in two MusicBee versions I'm using, there is a difference in how tracks with different disc numbers are sorted/grouped in the main panel (i.e. when I click on an album and the tracks are displayed).

Example: Three discs, three tracks each.

Basically, the "old version" 3.0.5995 sorted all tracks top-down, indicating groups with empty lines:

1 Disc 1, Track 1   6 Disc 2, Track 3
2 Disc 1, Track 2
3 Disc 1, Track 3   7 Disc 3, Track 1
                                8 Disc 3, Track 2
4 Disc 2, Track 1   9 Disc 3, Track 3
5 Disc 2, Track 2


The "new version" 3.4.7805 sorts tracks left-to-right and creates a new group for each, well, group.

1 Disc 1, Track 1   3 Disc 1, Track 3
2 Disc 1, Track 2

4 Disc 2, Track 1   6 Disc 2, Track 3
5 Disc 2, Track 2

7 Disc 3, Track 1   9 Disc 3, Track 3
8 Disc 3, Track 2


How can I restore the behavior of the old version?
I would like to keep multiple columns, so displaying tracks in a single column is not a suitable solution for me.
I would also like to continue using newer versions of the software, since they have some nice features.

I tried several (sub-)groupings with Album, Artist, Disc#, Disc-Track#, but I couldn't get the sorting to work the way I'm used to. I tried changed in the following sections of the Preferences, without success.
Layout (1), main panel, files: Customize Layout...,
- in Artwork: show the tracks for the selected album or artist, directly under the selected album or artist, Show Settings
- in Album and Tracks

I think this is supposed to be a feature, see https://getmusicbee.com/forum/index.php?topic=18462.0, changes since v3.0 Update 1
- expanded panel layout handling for multi-disc or sub-header grouping is improved so each disc/group starts on a new line

However, I'm relying on spatial memory, and using the newer versions I cannot find my tracks anymore..

Kind regards
Last Edit: May 29, 2021, 07:17:09 PM by heroclix

ma_t14

  • Hero Member
  • *****
  • Posts: 2393
Please post a screenshot. It will be easier then to see what you are referring to.

heroclix

  • Newbie
  • *
  • Posts: 11
Here's the picture: https://imgur.com/bMAzD61

I have also updated the description above, since I probably confused myself.

Please explain how I can get the wanted behavior. Thank you.

frankz

  • Hero Member
  • *****
  • Posts: 2841
You screenshot properly embedded:
A smile is happiness you'll find right under your nose.

heroclix

  • Newbie
  • *
  • Posts: 11
Hello again,
looks like there is no solution to this problem.

Could this thread please be moved to the Wishlist then?
I wish that my preferred sorting/grouping can be restored for my installation of MusicBee. I would hate to downgrade.

Thank you and kind regards

The Incredible Boom Boom

  • Hero Member
  • *****
  • Posts: 527
I dunno... Maybe you could try combining all the tracks into one disc, assign whitespace characters to an empty tag and use that tag to precede the sub-grouped tracks?

I'm not sure what the end result will be, but it could be somewhat close to what you're looking for.

I wouldn't get your hopes up about a reversion, considering this display characteristic hasn't been asked for back for three separate release versions.

heroclix

  • Newbie
  • *
  • Posts: 11
Hello and thank you for your proposal.

I did not manage to get this working.

First of all, I tried to stop MusicBee from grouping based on disc number. I failed. It seems tracks are always grouped by disc as a fallback, even if no grouping is selected in Layout (1), main panel (sub-grouping is empty in both "Artwork" as well as "Album and Tracks"). Even if I group on a tag that is empty for all tracks, the disc grouping is used.
I tried this, because it seems counter-intuitive to me to remove all the disc numbers I maintained (and that are correct).


Then (after discarding any disc numbering), I configured tag "Virtual1" using formula $If($Right(<Track#>,1)<=5,a," "), just to see how it would behave.
In the Artwork view configuration I changed the fields displayed from Title only to Virtual1 and Title.

This does not work, because "", " " and no argument in the formula are treated the same, resulting in the text "Unknown Virtual1" being shown ("a" works as expected).
Did you think of any other means I was supposed to use?

Note that this also causes the Artist (that is shown next to the Title for multi-artist albums) to disappear. This opens its own can of worms.


Please note that I do not ask for reversing the change. It would be sufficient for me if the old behavior could be an option somewhere in the preferences.

I know I'm probably the only person in the world who faces this problem and I do not have strong arguments to convice anyone to make this change. Maybe the old code still exists somewhere and can be added back, making the change easy?
It just makes me sad that something I relied on stopped working and there's no painless way to make it work again.

Kind regards

The Incredible Boom Boom

  • Hero Member
  • *****
  • Posts: 527
Then (after discarding any disc numbering), I configured tag "Virtual1" using formula $If($Right(<Track#>,1)<=5,a," "), just to see how it would behave.
In the Artwork view configuration I changed the fields displayed from Title only to Virtual1 and Title.

This does not work, because "", " " and no argument in the formula are treated the same, resulting in the text "Unknown Virtual1" being shown ("a" works as expected).
Did you think of any other means I was supposed to use?

What happens if you try another whitespace character?

heroclix

  • Newbie
  • *
  • Posts: 11
Hello again,

thank you for the hint. These other whitespace characters do work. However, the result is that the first line of each track is empty.

After testing with custom tags it seems that the lines for these data is either show for all tracks (even if it is empty for some tracks) or not at all, but never only for those tracks that have contents in their tags. I think I agree with this behavior in general, but to solve my problem I would need something like "show tag content only if filled".

Kind regards


heroclix

  • Newbie
  • *
  • Posts: 11
Hello again,

thank you for your idea. I can see how you thought of that function, but I think you came from the wrong direction.
With $IsNull I still need to provide two results, but any white space I provide causes the results described above.
What I think I need to set or provide is the null value itself. However, as we have seen that value (assuming "" is treated as null) produces the "Unknown..." text. In any case, an additional line is displayed.

Kind regards