Author Topic: MusicBee not displaying all album art  (Read 259 times)

Cyberlith

  • Newbie
  • *
  • Posts: 3
One thing I like about MusicBee is that it if I add additional album art (eg the single cover art too) it will cycle through it. However, it seems completely random whether it actually displays the alternate art. Sometimes it just doesn't seem to see anything but the primary art I first add in Mp3tag. The label for the file doesn't seem to matter, and it seems completely random whether it works for one mp3 vs another.

I also have come across mp3s where it doesn't see the cover art at all.

Is there any way to fix this? There is no consistency whatsoever. I add/edit my art using Mp3tag and some mp3s show all art, some show just the first art, others show no art whatsoever. It's a really irritating bug.

frankz

  • Hero Member
  • *****
  • Posts: 2760
"See it" where?

In Now Playing, if you right click the displayed artwork there should be the option for "enable image rotation"

If in the tag editor, then they will all be listed on the artwork tab.

Where in MB are you talking about?

All of my files have artwork either embedded or associated or both and MB sees it all and shows it where appropriate.  You need to describe what exactly you're having a problem with. Screenshots of the area where you expect to but are not seeing this art would help too.
A smile is happiness you'll find right under your nose.

Cyberlith

  • Newbie
  • *
  • Posts: 3
"See it" where?

In Now Playing, if you right click the displayed artwork there should be the option for "enable image rotation"

If in the tag editor, then they will all be listed on the artwork tab.

Where in MB are you talking about?

All of my files have artwork either embedded or associated or both and MB sees it all and shows it where appropriate.  You need to describe what exactly you're having a problem with. Screenshots of the area where you expect to but are not seeing this art would help too.
Enable Image Rotation is enabled and works in most mp3s.
It's in Now Playing that I'm having the issue. What's really strange is that with this one mp3 you see the primary cover art in the larger display, but in the Playing Tracks area you see a thumbnail of the other cover art. If you right click on the Now Playing larger cover art, though, that secondary art is not available to be selected nor does it rotate to it.

Cyberlith

  • Newbie
  • *
  • Posts: 3
Okay I moved "embedded" to the top of the priority list in options and that seems to have fixed this one mp3 at least. Hopefully it's taken care of the other issues.