Author Topic: Recovering album ratings  (Read 696 times)

Danielj

  • Newbie
  • *
  • Posts: 19
Hi, I've recently moved my MusicBee library to another computer (after not using that library for more than a year). I've imported the whole library and all settings, but somehow I've lost all of the old album ratings now. How can I get them back? I've always had "Save Ratings in Music File" on, though this might only be for track ratings?. I still have access to the original library on the other computer in case I can export it some way. It might be relevant info that I've had to relink the music file paths once.

I have some weird behavior too. Like if I make an auto-playlist with "any field has a value" and limit it to 5 random albums, it doesnt show anything. If I make it 50 random albums, it usually displays 0-5 albums. With 500 random albums it gives me around 25. I guess from this that there are a bunch of blank entries in the database.

The Incredible Boom Boom

  • Hero Member
  • *****
  • Posts: 899
Hi, I've recently moved my MusicBee library to another computer (after not using that library for more than a year). I've imported the whole library and all settings, but somehow I've lost all of the old album ratings now. How can I get them back? I've always had "Save Ratings in Music File" on, though this might only be for track ratings?. I still have access to the original library on the other computer in case I can export it some way. It might be relevant info that I've had to relink the music file paths once.

I would wipe the new library and start over by simply restructuring your music directories exactly how they were on your previous computer and then copying over all your setting files, instead of "import."
If your previous files were under C:\Users\Daniel J\Music, then you should create the same structure for your new ones, for example.

Danielj

  • Newbie
  • *
  • Posts: 19
I would wipe the new library and start over by simply restructuring your music directories exactly how they were on your previous computer and then copying over all your setting files, instead of "import."
If your previous files were under C:\Users\Daniel J\Music, then you should create the same structure for your new ones, for example.

This is working to get back the album ratings, thanks!

I'm still having the other issue when I'm trying to make a playlist of random albums (and I noticed now I have this issue on the older computer too, so the issue is not related to moving the library)

The Incredible Boom Boom

  • Hero Member
  • *****
  • Posts: 899
This is working to get back the album ratings, thanks!

I'm still having the other issue when I'm trying to make a playlist of random albums (and I noticed now I have this issue on the older computer too, so the issue is not related to moving the library)

I'm not sure what would be the cause of the playlist problem.
Can you attach a screenshot of your playlist settings?

Danielj

  • Newbie
  • *
  • Posts: 19
This is working to get back the album ratings, thanks!

I'm still having the other issue when I'm trying to make a playlist of random albums (and I noticed now I have this issue on the older computer too, so the issue is not related to moving the library)

I'm not sure what would be the cause of the playlist problem.
Can you attach a screenshot of your playlist settings?
[/quote]
For some reason I can't fully replicate the problem any more now. Although when I limit it to 300, it sometimes returns less albums (randomly between ~290 and 300). I have way more than 300 albums in my library. Here's the settings:

Danielj

  • Newbie
  • *
  • Posts: 19
I've simply started over with a fresh library and re-imported all my music files again now, since my library was such a mess (this is like the 5th time I'm moving it between computers).

I was ready to start over again with no album ratings, but to my surprise it seems like they have all been recovered now. I'm confused since I thought they were not stored in the files (only track ratings) but I guess I was mistaken about that. If that's the case I wonder why it didn't work to rescan the files to get the album ratings back... But it doesn't matter.

The Incredible Boom Boom

  • Hero Member
  • *****
  • Posts: 899
Sorry, I forgot to respond to this.
I can't really see anything in the settings that would keep you from getting the results you want and it doesn't seem like anyone else has a solution either.
Hopefully things are working better after the reset?

And getting the tags in all your files sorted out would definitely be the best way to ensure accurate results.