Author Topic: Be able to choose the 'Artist Field' for Last.fm Scrobbles  (Read 784 times)

TomK7104

  • Newbie
  • *
  • Posts: 13
Quote
@TomK7104, right-click on any track, which has display artist as multiple artists separated by ";" select "edit", then click "tag inspector". how multiple artists are written to id3 tags? as multiple ARTIST tags or as single ARTIST tag in the form "artsis1; artist2; artist3; etc"?  or better, post a screenshot of tag inspector.

Using the same file as listed earlier, here is what you asked for (Top Left - Tag Inspector showing the format of the tags. Multiple ARTIST tags present.):



No tags were edited after the file's creation (no DISPLAY ARTIST tag existed before adding to Musicbee Library)

hiccup

  • Hero Member
  • *****
  • Posts: 6562
You said that your mp3 files use ID3v2.3.
ID3v2.3 does not support multi-value tags, but your screenshot does show multi-value tags.
So the file tags must have been written by software set to use ID3v2.4
Make sure that program and MusicBee are set to use the same version.

boroda

  • Hero Member
  • *****
  • Posts: 4050
@hiccup, i've set mb to id3v2.3 and mb writes multiple artists tags.

@TomK7104, i can't reproduce this mb behavior, mb writes only 1st artist to display artist on my pc.

just as a workaround, you could install this plugin. select all tracks in your library (ctrl+A), right-click on them and select "additional tagging tools> multiple search & replace". set up MSR command as in screenshot below:



, i.e. set both "from tag" and "to tag" to "display artist", tick checkbox in the "(*)" column, search for:

^(.*?);.*$

replace by:

$1

, click "preview". you can save this MSR settings as "advanced search & replace" preset, and tick this preset in ASR command for auto-applying, so you won't need to do this replacement of "display artist" manually in future (e.g. if you add new tracks to library).
Last Edit: December 15, 2022, 10:33:55 AM by boroda

TomK7104

  • Newbie
  • *
  • Posts: 13
Quote
@TomK7104, i can't reproduce this mb behavior, mb writes only 1st artist to display artist on my pc.

just as a workaround, you could install this plugin. select all tracks in your library (ctrl+A), right-click on them and select "additional tagging tools> multiple search & replace". set up MSR command as in screenshot below:

Yeah, I've got that plugin already and tried to use it, but didn't know how to format it do things like that.

It worked perfectly, so I'll use this from now on. However I would like to note that "Display Artist" was not an option in the Tag drop-down menu. I have "Artist (displayed)" instead which worked.

Thought I'd let you know in case this is somehow related to Musicbee not automatically writing 1st artist to DISPLAY ARTIST tag.

boroda

  • Hero Member
  • *****
  • Posts: 4050
However I would like to note that "Display Artist" was not an option in the Tag drop-down menu. I have "Artist (displayed)" instead which worked.
you are using (probably, very) old version of plugin. i'd recommend to you to update it.

btw, if you was using this plugin, when your issue was happening, check if no other ASR presets are ticked for auto-applying. maybe some ASR preset is modifying display artist tag:

for the info for future users:

1. if any asr preset is ticked the color of warning text at the top of asr window is changed
2. to easily see all ticked presets (and only ticked presets) tick the checkbox in the yellow frame on screenshot:





TomK7104

  • Newbie
  • *
  • Posts: 13
Quote
you are using (probably, very) old version of plugin. i'd recommend to you to update it.

Yup, that was the problem. Now "Display Artist" tag appears and "Artist (displayed)" no longer exists.

Quote
btw, if you was using this plugin, when your issue was happening, check if no other ASR presets are ticked for auto-applying. maybe some ASR preset is modifying display artist tag:

I have no ASR presets activated, nor any showing in the preset box.

But yeah, this issue of mine where Display Artist doesn't automatically store the 1st artist is a little annoying. Would be great to figure out what is causing it.
Last Edit: December 16, 2022, 03:26:12 AM by TomK7104

miste

  • Newbie
  • *
  • Posts: 4
Hi guys, I've been trying this feature to auto apply this asr preset, but it seems the plugin is writing a different value, its writing "\T1" instead of the artist name. check my schreenshot:

boroda

  • Hero Member
  • *****
  • Posts: 4050
how have you created this ASR preset? manually or using MSR? and what you are trying to achieve? i don't understand you are expecting from "\T1" in replacement pattern.

also, better post screenshot of MSR window for this preset as it looks more user-friendly.

miste

  • Newbie
  • *
  • Posts: 4
how have you created this ASR preset? manually or using MSR? and what you are trying to achieve? i don't understand you are expecting from "\T1" in replacement pattern.

also, better post screenshot of MSR window for this preset as it looks more user-friendly.

I was trying to do the exact same thing as the OP. I configurated the script as you posted in Multiple Seach and replace first, then, I enabled to auto apply, but for some reason, its writing this weird text "\T1"


In the Multiple Search and replace window, it applies correctly, but in Advanced Search and Replace, it doesn't