Author Topic: Auto-organizer names files with latin special chars that MusicBee can't read  (Read 106 times)

amosmyn

  • Newbie
  • *
  • Posts: 6
Version: 3.3.7491 Store
(I would use the most recent version, but I can't update my Windows Store copy using the forum download)
Note: Auto-organizer is enabled

Suppose you have an external file with a "track title" field filled with "No Más" and import it. The default behaviour for the auto-organizer causes it to move the file to, e.g.,  "1-03 No Más.mp3", naming it after the "track title" field. At first, there are no issues with this convention as MusicBee behaves normally. However, upon reboot the file is flagged as 'missing' and can no longer be opened. You could rename the .mp3 file to replace the 'á' with an 'a' and import it again, which MusicBee successfully recognizes, but the auto-organizer will still rename the file back to the "track title" name and cause the same issue the next time MusicBee is restarted.

So two problems:
1) MusicBee cannot handle files with special latin characters after a reboot.
2) The auto-organizer names files with special latin characters. Even if (1) is fixed, this can be seen as an undesirable behaviour especially if external programs load the content at any time and have similar bugs (which is fairly common). Having a toggleable option for this might be useful.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31969
I dont think I will be able to help. That is the sort of issue that would have been reported and fixed many years ago

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10309
Yeah, I have lots of files with special characters, including various Asian scripts and Hebrew, and haven't had this problem. I suggest trying with a portable installation and see if it still happens. Could be an issue with the store version, Windows is not always cooperative.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.4)
(Unzip and overwrite existing program files)

amosmyn

  • Newbie
  • *
  • Posts: 6
Yeah, installing the portable edition seems to have done the trick.
I also have the many other special characters in my library, but for some reason it was only the Latin ones causing problems.

I'll check in after the Windows Store version updates to confirm whether the problem is specific to the WIndows Store.