Author Topic: Using Icon in Highlighting Feature (Alignment Issue)  (Read 3548 times)

G-Power

  • Jr. Member
  • **
  • Posts: 39

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9344
If you don't see it there's something wrong.
Nothing wrong here. I see the screenshot
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

G-Power

  • Jr. Member
  • **
  • Posts: 39
I tried everything up to clearing cookies + cache and restarting my browser. I'm not on a VPN.
Could you describe your screenshot in words or send it again, please?
Thanks!

phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9344
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

G-Power

  • Jr. Member
  • **
  • Posts: 39

Then the issue must be on my side, LOL.
I do have some internet security software (for blocking adult content, etc.) and it doesn't allow the imgur.com website for I-don't-know-what reason.
If that's the image host you're using, then I think that must be the problem. MediaFire and ImageShack are both accessible to me, though.

G-Power

  • Jr. Member
  • **
  • Posts: 39
Hey, me again. I've posted in this thread two days ago but, apparently, it didn't send.
Anyhow, I managed to get an "E" symbol outputted via "Virtual1" for explicit tracks. It's pretty cool because I've used Microsoft's Private Character Editor to generate a symbol that resembles the one used by Spotify and iTunes and all I had to do was apply it to all fonts. That way it works in Musicbee even if I decide to change the display font in the future.
Now my problem is that there are a lot of tags for which the values may not be displayed in the "Album and Tracks" view, for some reason. How do I manage to have the field for "Virtual1" displayed?
The only options I get when opening "Set Displayed Fields..." are "Love", "Highlight", "Track#", "Title", "Rating" and "Time". That's it. There's no option for virtual tags or any other tags, of what I can see.
Anyone know a fix?
Thanks!

hiccup

  • Sr. Member
  • ****
  • Posts: 7856
The only options I get when opening "Set Displayed Fields..." are "Love", "Highlight", "Track#", "Title", "Rating" and "Time". That's it. There's no option for virtual tags or any other tags, of what I can see.
Anyone know a fix?
You probably have Album and Tracks layout set to 'compact grid'.
If you change it to 'detailed list' more fields are available.

hiccup

  • Sr. Member
  • ****
  • Posts: 7856
… and all I had to do was apply it to all fonts. That way it works in Musicbee even if I decide to change the display font in the future…
That's interesting. Could you elaborate a little bit on how that works?

G-Power

  • Jr. Member
  • **
  • Posts: 39
That's interesting. Could you elaborate a little bit on how that works?

Absolutely.
I'm not sure how much you know about the editor so I'll just start from zero.
Open up the Run dialogue box and type "eudcedit.exe".
When that starts you get to select the code for your character. If you already have private characters you can select those for editing.
Once you're happy with your character, you can just save it. You can also save a copy of it to another code, if you like.
Now the character is set to be applied to all fonts by default, meaning that it will be recognised by any program using the fonts you already have on your system, whatever font that is.
But if you want to apply it to a specific font (e.g. Times New Roman), then you need to head to "File>Font Links..." and check "Link with Selected Fonts". That's it.
Now when comes the time to use it, you need to open "charmap.exe" and go to the font selection drop-down near the top of the window. If your character was applied to all fonts, then choose "All Fonts (Pricate Characters). Otherwise select the font that is specific to your character (anyway make sure you're using the Unicode character set; it won't appear otherwise).
Now just select the character, copy it, and that's it. I think you can also access it using the Alt+Num keyboard shortcut that's specific to your character code, but I'm not 100 % sure.
Hope this helps.