Author Topic: Tracks ending a second early  (Read 1255 times)

Eastern

  • Newbie
  • *
  • Posts: 12
This is an issue I've been having for some time now, I thought I solved it by tweaking a setting, but it seems to be back.
It's hard to tell how often it happens, but at least some tracks seem to end up to a second earlier than their actual runtime, cutting the end of the track off.
I've tried playing around with settings, but even adding 3 seconds of silence after each track doesn't fix this, and in fact doesn't seem to do anything at all.

It's not an issue with specific music tracks though, as windows media player correctly plays the full track.
What could be causing this issue, and how might I solve it?

frankz

  • Hero Member
  • *****
  • Posts: 3175
Check the end time on the files it happens to (on the settings tab of the tag editor) to make sure it's not set to end tracks early.

Otherwise all I can think of is a problem with your output settings and you'd have to trial and error it.
A smile is happiness you'll find right under your nose.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32906
if its not what frankz suggests, could you also confirm you don't have any dsp plugins enabled and that you dont have "skip starting and ending silence" ticked in the Player preferences

Eastern

  • Newbie
  • *
  • Posts: 12
Check the end time on the files it happens to (on the settings tab of the tag editor) to make sure it's not set to end tracks early.
Otherwise all I can think of is a problem with your output settings and you'd have to trial and error it.

End time doesn't seem to be the cause, it's defaulted to the true ending time it seems, as trying to increase the value automatically puts it back to this.

I haven't touched output settings previously, and the configure button is greyed out for all options.
Also worth noting I don't have any "ASIO devices".

if its not what frankz suggests, could you also confirm you don't have any dsp plugins enabled and that you dont have "skip starting and ending silence" ticked in the Player preferences
That setting is unticked, yes.

frankz

  • Hero Member
  • *****
  • Posts: 3175
Maybe the file header is hosed in some obscure way that only MB (or the bass library) reacts to. If it's an MP3 you can check/fix in mp3val if it's not an MP3 I'm assuming there are other tools for other formats.

Other than that I'm out of ideas.
A smile is happiness you'll find right under your nose.

Eastern

  • Newbie
  • *
  • Posts: 12
Maybe the file header is hosed in some obscure way that only MB (or the bass library) reacts to. If it's an MP3 you can check/fix in mp3val if it's not an MP3 I'm assuming there are other tools for other formats.

Other than that I'm out of ideas.
Sadly that doesn't seem to be the solution either.
Neat software though

sveakul

  • Hero Member
  • *****
  • Posts: 1907
Update to the latest 3.4.x version, apply the latest patch (https://getmusicbee.com/patches/MusicBee34_Patched.zip), add freshly-imported backup copies of the affected files, then do a "Rescan All Files" from Tools->Advanced->Rescan all Files.  You didn't say whether you had ALL DSP plugins disabled, just the "skip starting and ending silence" setting--check for any others also.

Finally, whitelist all MusicBee folders in any antivirus you may have.  Any change?

Eastern

  • Newbie
  • *
  • Posts: 12
Update to the latest 3.4.x version, apply the latest patch (https://getmusicbee.com/patches/MusicBee34_Patched.zip), add freshly-imported backup copies of the affected files, then do a "Rescan All Files" from Tools->Advanced->Rescan all Files.  You didn't say whether you had ALL DSP plugins disabled, just the "skip starting and ending silence" setting--check for any others also.
Finally, whitelist all MusicBee folders in any antivirus you may have.  Any change?
I'm not quite sure what you mean but DSP settings, but if you mean these, then yes all of them are off

I've done everything else you said, but the issue still persists.
Interestingly enough, I found out that if nothing else is queued up to play and the troubled track is the last thing to play, it will play the end of the track past when the program says 0:00
So it seems like the issue is that it tries to play the next track a second too early or something.

sveakul

  • Hero Member
  • *****
  • Posts: 1907
I'm not quite sure what you mean but DSP settings

I mean the ones in the list when you go to Prefs->Player->Equalizer & DSP (button);  then below the equalizer you should see a list like the below--uncheck everything.


Eastern

  • Newbie
  • *
  • Posts: 12
I'm not quite sure what you mean but DSP settings
I mean the ones in the list when you go to Prefs->Player->Equalizer & DSP (button);  then below the equalizer you should see a list like the below--uncheck everything.
Ah, I found them.
Everything is already unchecked here.

Eastern

  • Newbie
  • *
  • Posts: 12
Update to the latest 3.4.x version, apply the latest patch (https://getmusicbee.com/patches/MusicBee34_Patched.zip)
Unrelated to this issue, updating musicbee to that latest patch changed how the song list in mini mode looks.
It used to look more compact like the image on the right, but now it shows the album cover for each track.

frankz

  • Hero Member
  • *****
  • Posts: 3175
Right Click->Panel Layout->Playing Tracks->Track Details
A smile is happiness you'll find right under your nose.

Eastern

  • Newbie
  • *
  • Posts: 12
Right Click->Panel Layout->Playing Tracks->Track Details
It's already on 'Track Details'. Changing between the 3 options there doesn't actually change anything oddly.

Mog666

  • Newbie
  • *
  • Posts: 1
Hi, I am posting here to let you know that I am having a very similar problem so this isnt isolated.
I have disabled crossfade and add silence and I have no DSP selected.
It happens very often that it will cut the end off random songs, if I go back and play the song again it will get all the way through.
I dont think it is specific to particular files, also I think a related issue is randomly replaying the first second of the songs too.
Thanks for any help.
Happy Holiday!
UPDATE!
I think for me "increase buffer size" setting seems to have fixed the problem.
Last Edit: January 06, 2021, 07:37:25 PM by Mog666