Author Topic: Edits with Tag Inspector  (Read 1000 times)

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6259
I'm not sure this is a bug, but it is certainly unusual behavior. Using 3.4.7626 P, but I've seen it occasionally on various versions going back probably a year or so.

I select a track and open the Tag Editor. I then open the Tag Inspector and edit a tag and save it. The Tag Editor then flashes the red warning icon next to the Save button. The warning states that "the file(s) being edited have been updated outside of MusicBee - you may need to rescan..."

This is incorrect. The file(s) were edited using the Tag Inspector. Does the warning mean that editing with the Tag Inspector requires a rescan? I've never seen those changes not picked up by MB when saving the Tag Editor.
Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

hiccup

  • Editor
  • Hero Member
  • *
  • Posts: 4423
Same here. (also for at least a year I think)
But I never made an effort in analyzing and replicating the exact circumstances when this happens, so I also didn't report it.
But it's a real thing for sure.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6259
But it's a real thing for sure.
Thanks for confirming my sanity, albeit temporary.
Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

hiccup

  • Editor
  • Hero Member
  • *
  • Posts: 4423
Thanks for confirming my sanity, albeit temporary.

Not addressing the sanity part (I have a meeting about you with some other white-coated fellows later on), but I am pretty sure this was raised before.
Even in the last week by a French forum member I believe. (I now can't find that post though)

I do recall it occurring a few times when I had both the tag editor docked at the bottom, and the vertical tag editor open.
But I can imagine that that is asking for some problems.

But it also happened with using only the docked tag editor.
Perhaps I will put some effort in trying to replicate it and focus on the the circumstances the coming week.
Last Edit: November 18, 2020, 05:50:11 PM by hiccup

The Incredible Boom Boom

  • Sr. Member
  • ****
  • Posts: 350
I do recall it occurring a few times when I had both the tag editor docked at the bottom, and the vertical tag editor open.
But I can imagine that that is asking for some problems.

But it also happened with using only the docked tag editor.

Now that it's been mentioned, I too have also been seeing the warning icon more often since I docked the Tag Editor and when making changes inside MusicBee. I'll try undocking it and messing around and see if it's as frequent.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6259
I don't use the docked Tag Editor. Mine is a separate floating window.
Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6259
Not addressing the sanity part (I have a meeting about you with some other white-coated fellows later on)
When the meeting ends, if there's an extra white coat with long sleeves and strings at the end, save it for me.
Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31760
Are the files on a network share? There have been some reports of this before and the diagnosis was that it takes some time for the file modification time to update ie. MB gets the old modification time
If these are network share files, I might disable the functionality for UNC paths but if you have it mapped to a drive letter then it will still behave the same way


phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6259
Are the files on a network share?
Yes, my files are on a partition of my NAS which I have mapped as drive letter Z:
Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here

The Incredible Boom Boom

  • Sr. Member
  • ****
  • Posts: 350
Are the files on a network share?
Yes, my files are on a partition of my NAS which I have mapped as drive letter Z:

Same here, but mine aren't mapped.

frankz

  • Editor
  • Hero Member
  • *
  • Posts: 2438
I, too, feel like I have been seeing the "updated outside MB" warning more recently - network share no drive mapping. 

Mr. Trev

  • Sr. Member
  • ****
  • Posts: 304
I'll jump in with a me too.

NAS. Network share, Not drive mapped.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31760
and is this only after saving with the tag inspector?

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6259
and is this only after saving with the tag inspector?
While not 100% of the time, yes, I've only see it when saving a tag or tags using the Tag Inspector.
Download the latest MusicBee v3.3 patch from here.
Download the latest MusicBee v3.4 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here