Author Topic: Subsonic Client  (Read 84614 times)

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6708
This plugin is the only way I can play subsonic server stuff on a windows 10 computer.
It's certainly not the "only" way.
You can also use your web browser to reach your server. From -any- computer running -any- OS, from -any-where.
Download the latest MusicBee v3.4 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

Gerd

  • Newbie
  • *
  • Posts: 2
Hi, i would love to use MusicBee with my Nextcloud installation using the Nextcloud Music app, but somehow i can not connect to its supersonic api. No matter what settings i chose, the supersonic plugin always tells me on ping requests that the server did not respond to ping as expected and i get no tracks displayed in the subsonic folder. any ideas, or can i do somethig to help debugging?

btw, i can perfectly connect to my Nextcloud using Subsonic android app, clementine also works, but its uggly and takes ages to load the library...
Last Edit: April 25, 2020, 05:53:01 PM by Gerd

Gerd

  • Newbie
  • *
  • Posts: 2
seems i am not the first to try this without success, however, i can not even make it detect the subsonic server...

Hello,

My music collection is stored on a Nextcloud server, at home. I have enabled the "music" app (version 0.11.0) to allow streaming the audio files from my collection to external applications compatible with Subsonic (and Ampache).

On my Arch Linux laptop I use "Clementine" which has built-in capabilities to stream from a Subsonic server. This works perfectly.

On my work laptop (Windows 10) I have installed MusicBee and, following the instructions kindly provided by MiDWaN on GitHub, I tried to configure the plugin as shown below:



The music app shows this address to use when browsing the music collection from a Subsonic compatible player:

Code
https://<my.home.server>:<port#>/index.php/apps/music/subsonic

This combination of "hostname" and "port number" is the only one which make possible the main MusicBee window to show "Detected a Subsonic server" and ""Done running GetFolderFiles" messages in the lower left corner (see images below).





The issue is that no audio file from my collection is shown (as you can see in the two images above).

Other details which may help in troubleshooting the issue:

Subsonic Client v2.28.00
MusicBee version: 3.3.7261
Nextcloud version: 16.0.5 running on Ubuntu 18.04.3 LTS
I have a static IP from my ISP


wortoltje

  • Newbie
  • *
  • Posts: 1
Same problem as Valentin, except for using Nextcloud.
I can connect with my Subsonic server and when I try to go to my Subsonic tab in Musicbee albums do show up after a refresh, but i get a message that the directory is NOT FOUND. Also full albums are indicated as single songs with length 0:00 .

Note that this only happened when accessing my full music library. When I tested this with 10+ albums I didn't experienced this problem...

Hello,

My music collection is stored on a Nextcloud server, at home. I have enabled the "music" app (version 0.11.0) to allow streaming the audio files from my collection to external applications compatible with Subsonic (and Ampache).

-------
-------
-------

The issue is that no audio file from my collection is shown (as you can see in the two images above).

Other details which may help in troubleshooting the issue:

Subsonic Client v2.28.00
MusicBee version: 3.3.7261
Nextcloud version: 16.0.5 running on Ubuntu 18.04.3 LTS
I have a static IP from my ISP


dabeastro

  • Newbie
  • *
  • Posts: 4
Thank you so much for your work on this. I've got an Airsonic server working well with this. It populates nicely in the computer node. Node shows up as an option for monitoring.  Nothing happens with this though. So I resorted to just selecting all the files and doing an send to music library. That works pretty well, but will of course need to be done every time I add music to the server. Is this the best/only way to achieve getting the subsonic files into the MB library? Just checking to see if maybe I am missing something on the server side. Thanks again!

MiDWaN

  • Jr. Member
  • **
  • Posts: 68
It's been quite a while, I know... But I have a new release for you!
https://github.com/midwan/MB_SubSonic/releases/tag/v2.30

This one fixes several issues, removes the problematic pre-caching function and background tasks, and hopefully works better for you.

MiDWaN

  • Jr. Member
  • **
  • Posts: 68
New bugfix release is out: https://github.com/midwan/MB_SubSonic/releases/tag/v2.31

This fixes a problem with some Subsonic-compatible servers (e.g. Ampache), which failed to connect after the previous updates.

alexprevity

  • Newbie
  • *
  • Posts: 4
Hey all! Not sure if this is the right place to ask this, but I'm pretty sure the issue I'm experiencing is specific to the Subsonic plugin. In the Computer panel on the left, if I left click on a parent folder that is local to my PC (no matter how many sub-folders there are), it shows all of that folder (and its sub-folders') tracks in the Tracks panel in the center. However, if I'm under the Subsonic section of the Computer panel that the plugin added, I cannot see any tracks in the Track panel unless I left click on the lowest folder hierarchically. So if I have Music (Subsonic folder) > Globe (artist) > Global Trance (album), if I click on "Globe", the Track panel shows nothing. But if I click on "Global Trance", the Track panel does indeed show all of the tracks in that folder. Is this just a limitation of the Subsonic plugin, or is there something I can configure to have it show up as expected? Ideally, I would like to be able to select the highest folder I have available under Subsonic ("Music"), and be able to browse Artists as dictated by the metadata.

Thanks!

MiDWaN

  • Jr. Member
  • **
  • Posts: 68
This is by-design. The subsonic server is on the network, and unless you have a local offline database you cannot expect to get the whole list of tracks from the server without delays. So the decision was to show only the contents of the selected folder, instead.
The alternative is to browse by Tags, as you mentioned. But that is a separate function in Subsonic (different API calls, different handling) which hasn't been implemented in the plugin, yet. It's in the TODO list for the future...

alexprevity

  • Newbie
  • *
  • Posts: 4
Okay, that makes sense to me! It would be a lot of info to pull down for sure.

On another note, I was wondering something else - I was wanting to make an Auto Playlist locally in MusicBee. It seems that I am choose Subsonic in "music track source", but nothing populates at all in the Auto Playlist, no matter what criteria I set up. Is this just a limitation of how the Subsonic plugin works?

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6708
I was wanting to make an Auto Playlist locally in MusicBee
I don't use this plugin, but I do use Subsonic. Unless I'm misunderstanding what you're trying to do, you should create the auto-playlist in MB. Then it will (should) show up on Subsonic just like any other playlist.
Download the latest MusicBee v3.4 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

alexprevity

  • Newbie
  • *
  • Posts: 4
I don't use this plugin, but I do use Subsonic. Unless I'm misunderstanding what you're trying to do, you should create the auto-playlist in MB. Then it will (should) show up on Subsonic just like any other playlist.

Unfortunately, even though MusicBee technically allows you to choose Subsonic as the media library source for the playlist, it does not end up finding any files since they are not local files (and only are populated via the plugin). So at this point it does not seem possible to use MusicBee auto playlists with Subsonic media source. For now I am using a "smart playlist" Subsonic workaround, and MusicBee pulls those down just fine!

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6708
Are you creating your playlists on Subsonic and playing them on MB?

I have MB running on my PC. It exports playlists (auto and static) any time there's a change. Subsonic is also running on the same PC. The music files are on a NAS, with its directory mapped to a drive letter. Subsonic scans the music files (on the NAS) and the playlist files (on a PC) once a day and updates Subsonic. Subsonic has no trouble seeing/playing the playlists.

Where is MB installed?
Where are you playlists?
Where are you music files?
Are you exporting your MB playlists?
Is Subsonic not seeing them?
Do you have MB set up correctly to export the playlists? And are you remapping the file path(s)?
Download the latest MusicBee v3.4 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

alexprevity

  • Newbie
  • *
  • Posts: 4
Are you creating your playlists on Subsonic and playing them on MB?

I have MB running on my PC. It exports playlists (auto and static) any time there's a change. Subsonic is also running on the same PC. The music files are on a NAS, with its directory mapped to a drive letter. Subsonic scans the music files (on the NAS) and the playlist files (on a PC) once a day and updates Subsonic. Subsonic has no trouble seeing/playing the playlists.

Where is MB installed?
Where are you playlists?
Where are you music files?
Are you exporting your MB playlists?
Is Subsonic not seeing them?
Do you have MB set up correctly to export the playlists? And are you remapping the file path(s)?


I don't have any issue getting manual playlists created in MusicBee showing up in Subsonic! That part works fine. My issue is within MusicBee itself.

MusicBee is installed on my PC, and my music files live on my Synology NAS. The NAS is not able to be mounted to my PC as a remote drive, so I use my Mac to connect to the NAS to manage its media organization via iTunes. The issue is that if I create an auto playlist in MusicBee, it cannot properly see music that I access via the Subsonic MB plugin. I can easily make manual playlists with Subsonic source in MB, but the auto playlist feature does not seem to play nice with the Subsonic plugin. For example, I would want MusicBee to make an auto playlist with any "loved" songs with the "VGM" genre. No matter what I try and do with any criteria, MB auto playlists cannot see Subsonic media, even if you are able to technically select Subsonic as the media source in the auto playlist settings menu.