Author Topic: Radio playback issues  (Read 1329 times)

wobblycogs

  • Newbie
  • *
  • Posts: 2
I listen to a radio station through MusicBee called "The Rock" (New Zealand) for which I use the stream URL

https://livestream.mediaworks.nz/radio_origin/rock_128kbps/chunklist.m3u8

I find that approximately every thirty seconds MusicBee briefly cuts out and restarts the stream, this doesn't happen when the station is played through the browser.

The M3U8 file that points to the stream has the following typical contents:

Code
#EXTM3U
#EXT-X-VERSION:3
#EXT-X-TARGETDURATION:11
#EXT-X-MEDIA-SEQUENCE:50239
#EXTINF:10.03,
media-uvjthehn8_50239.ts
#EXTINF:10.031,
media-uvjthehn8_50240.ts
#EXTINF:9.961,
media-uvjthehn8_50241.ts


This appears to define three tracks of approximately 10 seconds each. I believe MusicBee is playing these and then reloading the stream to get information about the next three tracks.

Examining the stream playing in the browser using the developer tools in Chrome leads me to believe that is preloading the next playlist when the last track of the existing playlist loads. This leads to a seamless playback experience.

Would it be possible to make MusicBee copy the behaviour of the in browser player?

I'm running MusicBee version 3.3.7491. This issue has been present for as long as I can remember.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33474
Trying now it with the v3.4 it works fine
https://getmusicbee.com/patches/MusicBee34_Patched.zip
unzip and replace the existing musicbee application files

edit:
actually the solution is to use bass_aac.dll
see the FAQ section for instructions on how to get it

wobblycogs

  • Newbie
  • *
  • Posts: 2
Many thanks, adding bass_aac.dll seems to have fixed the problem.

Mark Morris

  • Jr. Member
  • **
  • Posts: 24
Trying now it with the v3.4 it works fine
https://getmusicbee.com/patches/MusicBee34_Patched.zip
unzip and replace the existing musicbee application files

edit:
actually the solution is to use bass_aac.dll
see the FAQ section for instructions on how to get it
Hi. I've tried both of those solutions, but all three hls/m3u8 stationsI listen to still glitch every 30 seconds. Is there any other  solutions? Thanks!

sveakul

  • Hero Member
  • *****
  • Posts: 2034
Hi. I've tried both of those solutions, but all three hls/m3u8 stationsI listen to still glitch every 30 seconds. Is there any other  solutions? Thanks!

First, please confirm that you have updated to the latest MusicBee 3.4x version from the post here: https://getmusicbee.com/forum/index.php?topic=32142.msg189107#new .

I have no problem running this stream without gaps.  Try updating basshls.dll to the latest development version (2.4.2.3) from the package here: www.un4seen.com/stuff/basshls.zip .  Also update bass_aac.dll to 2.4.5.20 (if you haven't already done so) from here: www.un4seen.com/stuff/bass_aac.zip .