Author Topic: Right-Click and selecting Edit or pressing Shift-Enter won't do anything!!  (Read 944 times)


  • Newbie
  • *
  • Posts: 2
When I first installed MusicBee portable I was using it for several months and had no issues.

But recently something has broken and I can no longer right-click a song or songs and press 'EDIT'. I also cannot press SHIFT-ENTER to bring up the songs properties and tags.

Here's what I've done to attempt to fix it but nothing has worked.

1: Updated MusicBee Portable to the latest version - 3.3.7491 P

2: I found an old Forum that said dual monitors can screw with MusicBee, so I disconnected my second monitor and tried again. No luck.

I cannot for the life of me figure out what's going on, but it basically breaks my ability to manage music. It was working fine but then stopped for no reason.


  • Newbie
  • *
  • Posts: 12
This may be an over-simplistic option, but are you sure the hotkey for EDIT hasn't been deleted or changed? Right clicking and selecting EDIT is only activating the hot key (SHIFT+ENTER) so if that is wrong, it won't work.

Go to Edit / Edit Preferences and then select Hotkeys from the left vertical menu. Scroll down on the right side and select Edit:Edit Tags if it isn't set to SHIFT+ENTER then there's your problem. You can always set it to something else (unique) to see if that works or convert it back to it's normal default of SHIFT+ENTER.

No guarantee that this will be the problem but it's worth a look.

Hope it helps.


  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 10693
Hi, welcome to the forum!

Besides sig.ovia's idea, one thing that could be happening is that MusicBee thinks the edit window is on another monitor. That should have been fixed when you disconnected the second monitor, but if it was confused in the first place, maybe it didn't help. I'm trying to find the setting to reset that, bur no luck yet. Maybe someone else knows.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)


  • Administrator
  • Sr. Member
  • *****
  • Posts: 34032
Yes I would think the issue is the tag editor window is being displayed in an inactive screen, although MB does have checks in place for that, I guess it doesnt always work.
If you delete the file: DialogStateSettings.dat in the musicbee appdata folder then that will reset the display location for the window


  • Newbie
  • *
  • Posts: 2
Thanks guys, I appreciate all your quick and informative responses :D. I checked the Hotkey 'Shift-Enter' settings in preferences as per Sig.Ovia's suggestion - Good idea - although the hotkey was still set correctly.

However, in a weird turn of events, the 'Edit' window is now working. But, there is something different about the way i'm viewing MB this time so i'll describe what's changed and maybe you guys might be able to figure out what fixed it.

I'm currently working remotely, so instead of sitting in front of my primary office computer with two screens, i'm remotely controlling it via a Windows RDP session. Naturally this locks my session down to only one screen, so could this dual screen thing really be the cause perhaps? If so, it's strange that it didn't work when I disconnected my second screen earlier.

So far it works fine as I use MB via remote RDP session. I'll be keen to see how it works when I return to my office and use MB sitting in front of the computer with dual screens.

If I continue to have the issue, i'll try Steven's fix. :-)

I'll keep you all posted once I've tried it.