Author Topic: Android remote  (Read 95620 times)

scottjay

  • Guest
Don't know if you have fixed this but the track's title is also glitchy. It only shows when I have the menu up or pull the notification bar down.

Great work by the way.  :D

Smutzig033

  • Guest
I noticed that too. Great app though! It would be nice if you could browse your library on your android too, Gmote does have that function, but it plays the files in an other program, not musicbee. This way I can't scrobble my plays to last.fm. Your app takes care of that, but it would be nice to have a 'browse' function.

kelsos

  • Sr. Member
  • ****
  • Posts: 302
Library browsing is on the TODO list for the application. by the way when you say glitchy? what exactly do you mean can you provide some screenshots or something?

JanW

  • Guest
Had to register just to congratulate kelsos on your amazing work!
Felicitaciones desde Chile!

scottjay

  • Guest
The track title text is invisible unless the app is unfocused? It appears when the menu key is pressed, the notification bar is pulled down and even when I take a screenshot. Otherwise, when using the app, it does not appear.

Maleko12

  • Member
  • Sr. Member
  • *****
  • Posts: 658
I found the problem: my computer's ip address was changed on the network, but the app was reference the old ip address, which caused it to instantly crash until i cleared data and changed. notifications version still crashed instantly freshly installed

I tried deleting the data and putting in my static ip address, and it still force closes instantly. Using 2.3.3 Gingerbread.

scottjay

  • Guest
I found the problem: my computer's ip address was changed on the network, but the app was reference the old ip address, which caused it to instantly crash until i cleared data and changed. notifications version still crashed instantly freshly installed

I tried deleting the data and putting in my static ip address, and it still force closes instantly. Using 2.3.3 Gingerbread.

Weird, seems that was the cause of my problems. You are using the right network ip right?


h4nn4h

  • Guest
Hello,

Thanks for your efforts, developer(s)! The application looks really useful, but I'm having troubles getting it to connect. I'm pretty sure my IP address is right (found it via ipconfig, the one that starts with 192.168...,right?), and I'm using the standard port (3000), but all I get is a connect error after a couple of minutes. Am I overlooking something?


titule

  • Jr. Member
  • **
  • Posts: 21
Hello,

Thanks for your efforts, developer(s)! The application looks really useful, but I'm having troubles getting it to connect. I'm pretty sure my IP address is right (found it via ipconfig, the one that starts with 192.168...,right?), and I'm using the standard port (3000), but all I get is a connect error after a couple of minutes. Am I overlooking something?


Did you open your firewall on the PC?

h4nn4h

  • Guest
Hello,

Thanks for your efforts, developer(s)! The application looks really useful, but I'm having troubles getting it to connect. I'm pretty sure my IP address is right (found it via ipconfig, the one that starts with 192.168...,right?), and I'm using the standard port (3000), but all I get is a connect error after a couple of minutes. Am I overlooking something?


Did you open your firewall on the PC?

Not consciously, but I do see MusicBee in the list of allowed programs in my firewall settings (twice, with the boxes checked). Should that be enough, or do I need to open the port on my router or something?

titule

  • Jr. Member
  • **
  • Posts: 21
Hello,

Thanks for your efforts, developer(s)! The application looks really useful, but I'm having troubles getting it to connect. I'm pretty sure my IP address is right (found it via ipconfig, the one that starts with 192.168...,right?), and I'm using the standard port (3000), but all I get is a connect error after a couple of minutes. Am I overlooking something?


Did you open your firewall on the PC?

Not consciously, but I do see MusicBee in the list of allowed programs in my firewall settings (twice, with the boxes checked). Should that be enough, or do I need to open the port on my router or something?

Depends on what the checkboxes mean...  :)
I don't think you need to open the router, assuming we are talking about the usual home-use router that connects your LAN with the internet and both, PC and SmartPhone are part of the LAN.
I usually do it like this: set the firewall to "learn"mode and wait for the question window telling me that something wants to connect to the PC or that something on the PC acts as a server.
To test, you may also turn off the firewall and try to connect. If it works, then you need to change the firewall setup. But don't let it open for too long, there are "dragons and beasties out there in the night to snatch you if you fall".

h4nn4h

  • Guest
Hello,

Thanks for your efforts, developer(s)! The application looks really useful, but I'm having troubles getting it to connect. I'm pretty sure my IP address is right (found it via ipconfig, the one that starts with 192.168...,right?), and I'm using the standard port (3000), but all I get is a connect error after a couple of minutes. Am I overlooking something?


Did you open your firewall on the PC?

Not consciously, but I do see MusicBee in the list of allowed programs in my firewall settings (twice, with the boxes checked). Should that be enough, or do I need to open the port on my router or something?

Depends on what the checkboxes mean...  :)
I don't think you need to open the router, assuming we are talking about the usual home-use router that connects your LAN with the internet and both, PC and SmartPhone are part of the LAN.
I usually do it like this: set the firewall to "learn"mode and wait for the question window telling me that something wants to connect to the PC or that something on the PC acts as a server.
To test, you may also turn off the firewall and try to connect. If it works, then you need to change the firewall setup. But don't let it open for too long, there are "dragons and beasties out there in the night to snatch you if you fall".


I couldn't find a "learning mode" on my firewall (it's just the standard windows 7 one), but I did try turning it off for a couple of minutes, and still got the same connect error. So if it's not the firewall, what else could the problem be? I don't think there's a general connection problem between the phone and the rest of the network (which is indeed a simple one, as you describe), because I don't have any problems with VLC remote, for instance...

kelsos

  • Sr. Member
  • ****
  • Posts: 302
If MB is allowed to listen for connections and not blocked through the windows 7 firewall as long as the smartphone and computer are on the same network it should work.

Say for example the Computer is connected through an ethernet cable to the router and the smartphone is connected through WiFi. The router gets some kind of IP like 192.168.a.x, the computer should get an IP address like 192.168.a.y and the phone should have and another one like 192.168.a.z.

The application has been tested with desktop<->ethernet<->router<->wifi<->smartphone setup and also with laptop<->wifi<->router<wifi>smartphone setup.

There are some wireless routers that support Wireless Access Point isolation, meaning the wireless devices on the network have no access on the other devices in the same network). Are you sure computer and phone can communicate outside of the remote application?

Blackened

  • Jr. Member
  • **
  • Posts: 76
Kel, I just wanna say thank you for this one man, I know it's in Beta/Alpha stuff but it works perfectly.

What I like about it, is when the program aren't working they just reboot and reselect and work perfectly. I wasn't annoyed on that but it sure helps a lot.