Author Topic: Add Deezer as search engine  (Read 5302 times)


phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9441
You'd have to figure out how its search routine works. I'd start by copying one of the other link templates you already have and copying it to the Deezer spot, change the URL to Deezer's and see what happens. It's going to be trial and error until you get the results you're looking for.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here


phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9441
I suppose it's possible it doesn't allow links with search criteria. I've come across a couple like that over the years.

If  they -do- allow them, then you'll just have to play with it until it works. Or ask over at Deezer.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here


hiccup

  • Hero Member
  • *****
  • Posts: 8003
This seems to work:

Code
https://www.deezer.com/search/<Album Artist> <Album>

Code
https://www.deezer.com/search/<Artist> <Title>

stardepp

  • Sr. Member
  • ****
  • Posts: 371
👍✨😎 Thanks @hiccup that works 🍀

with MusicBee all wishes come true 🍀✨😎

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9441
This seems to work:

Code
https://www.deezer.com/search/<Artist> <Title>

Interesting. I'm pretty sure I tried that and wound up with a 404. Or maybe a 403.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here

stardepp

  • Sr. Member
  • ****
  • Posts: 371
It definitely worked for me. I disabled the web browser plugin, and so the links end up in my default browser Vivaldi.

Right beside I can highly recommend the browser Vivaldi.

Just as versatile configurable as MusicBee.

https://vivaldi.com



hiccup

  • Hero Member
  • *****
  • Posts: 8003
Truth be told: it wasn't the most difficult one to figure out:


 

stardepp

  • Sr. Member
  • ****
  • Posts: 371
Yeah, you're a Hero Member and I'm a Sr. Member. I spent two hours this morning trying in vain to find the right URL.

hiccup

  • Hero Member
  • *****
  • Posts: 8003
Yeah, you're a Hero Member and I'm a Sr. Member. I spent two hours this morning trying in vain to find the right URL.

That 'hero' label doesn't say that much, it's just a count of the amount of posts of a user.
(I'm not sure, 500 or so?)
So somebody that just asks a lot of questions will also automatically become a hero one day.

(I just hope I am not triggering other members to start asking lots of silly questions now ;-)

frankz

  • Hero Member
  • *****
  • Posts: 3868
This seems to work:

Code
https://www.deezer.com/search/<Artist> <Title>

Interesting. I'm pretty sure I tried that and wound up with a 404. Or maybe a 403.
Same here with <Album Artist> <Album>.  I did the same thing @hiccup did which was go to Deezer and run a search and then it worked once in MB but didn't work subsequently.

hiccup

  • Hero Member
  • *****
  • Posts: 8003
Same here with <Album Artist> <Album>.  I did the same thing @hiccup did which was go to Deezer and run a search and then it worked once in MB but didn't work subsequently.

Interesting. What browser are you using?
(FireFox here)
Or perhaps some browser plugin that obstructs something?

edit
Or, maybe Deezer has some time counter for subsequent searches this way?
Last Edit: April 29, 2020, 06:09:07 PM by hiccup

frankz

  • Hero Member
  • *****
  • Posts: 3868
Chrome, but I think it has something to do with the content of the search.

Spacehog - As it is On Earth works fine

Samia - Lasting Friend / Paris does not (HTTP_NOT_FOUND although it exists on Deezer)

The B-52's - Whammy! works fine

Maybe it's just slashes that create a problem.