Author Topic: wasapi exclusive - quality & stuck autoplay  (Read 6502 times)

hiccup

  • Sr. Member
  • ****
  • Posts: 7856
There's no point in bypassing windows mixing just to add some other DSP. It's nonsensical.

Just for the sake of this thread, and what urfausto (thinks he is) trying to achieve I agree.

But if you are serious about audio quality and you know what you want and you know what you are doing, you could want to use a good quality dsp plugin, and avoid the Windows mixer interfering with e.g. changing sample rate etc.

urfausto

  • Full Member
  • ***
  • Posts: 167
PS,

By keeping editing your posts (even the initial one) after other members replied, you run the risk of making things even more confusing for people who stumble upon this thread.
sorry but many times i myself don't know what the hell is going on so i go into correction in the hope of making everything more clear for others, else it seems nonsensical to me with different topic and discussion.
Last Edit: April 17, 2020, 08:49:34 PM by urfausto

urfausto

  • Full Member
  • ***
  • Posts: 167
What do you think windows mixing is? People avoid it because they don't want whatever DSP it might add.  They want MusicBee -> DAC -> Ears.

There's no point in bypassing windows mixing just to add some other DSP. It's nonsensical.
there is a point in my opinion if i like some effects, but is there a way to avoid windows and keep dsp effects? currently i am still using musicb dsp, i just disabled one plugin. i like mine and musicb plugins a lot actually.

urfausto

  • Full Member
  • ***
  • Posts: 167
"WASAPI has four different modes of operation. SONAR supports WASAPI Exclusive mode and WASAPI Shared mode.
Exclusive mode provides low latency audio and direct access to the audio driver, bypassing the Windows audio engine. The disadvantage is that only one application can access the driver in Exclusive mode." - https://www.cakewalk.com/Documentation?product=SONAR&language=3&help=AudioPerformance.29.html

https://www.multimediasoft.com/amp3dj/help/index.html?how_to_wasapi.htm


from these i think that my dsp plugin is acting like an application... what a shame, this should not happen...  :-\

urfausto

  • Full Member
  • ***
  • Posts: 167
update:

i asked for support to the plugin creator and correctly solved my problem which actually is in the 5.1 upmix option from musicbee. i deactivated this and all dsp work flawlessly again.