Author Topic: Manage duplicates is seeing asx files as duplicates  (Read 392 times)

MUSICWASP

  • Newbie
  • *
  • Posts: 1
Hi,

Just starting to use Musicbee and most things seem to make sense so far except this.

So if I import an entire discography of an artist I no doubt get duplicates...  then I use Manage Duplicates to delete the duplicates and replace them with asx files so each release appears 'complete'.

Then next time I scan the library using Manage Duplicates it sees all my asx files as duplicates to the file each asx is pointing to.

Is there a way for the Manage Duplicates scan to ignore asx files? I had a look around in the preferences (which there are a lot of) and nothing jumped out at me.

Would appreciate any help you can offer.

Cheers!

hiccup

  • Sr. Member
  • ****
  • Posts: 7936
welcome to the forum musicwasp
This needs the file extension being added as a condition.
How to do that is currently a bit hidden and not easily available:

     • create a virtual tag 
       label: Extension 
       formula: <.Ext> 

     • add that tag as a condition in the fitered files option in the Duplicates Manager: 
       Selected tags > More > Extension 
 
There exists an open wish to make this a bit easier and less hidden b.t.w.:
https://getmusicbee.com/forum/index.php?topic=39616.msg214236#msg214236

+1-ing it might help getting this suggestion implemented.
Last Edit: September 07, 2023, 08:18:46 PM by hiccup

tjinc

  • Sr. Member
  • ****
  • Posts: 363
Hiccup just beat me to it - I went with:

A workaround would be to create an auto playlist with the criteria .Ext - is not - asx and run the duplicates manager on that playlist.

hiccup

  • Sr. Member
  • ****
  • Posts: 7936
Hiccup just beat me to it - I went with: …
The more good suggestions for alternative ways to reach a goal the better!