Author Topic: Adjust the virtual tag  (Read 900 times)

Sofocl

  • Sr. Member
  • ****
  • Posts: 304
Help to Adjust so that the album is not displayed if the first rule is executed;

$If($Contains(<Title>,": ")="F",,$Split(<Title>,": ",1)) $IsNull(<Title>,<Album>,<Album>)
Sorry for my bad English.

smann

  • Jr. Member
  • **
  • Posts: 58
Helps to explain in detail exactly what you are trying to achieve. I can't quite follow what you're looking for from that tag.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10678
If I understand what you're asking for, try this:

$If($Contains(<Title>,": ")="F",$IsNull(<Title>,<Album>,<Album>),$Split(<Title>,": ",1))

Then if title is not null AND does not contain ":" the album will be displayed.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3768
  • MB Version: 3.5.8279 P
if title is not null AND does not contain ":" the album will be displayed.

I find if you work from what you least want to what you most want in the virtual tag, you end up with the shortest expression:
$IsNull(<Title>,<Album>,$If($Contains(<Title>,": ")="T",$Split(<Title>,": ",1),<Title>))

MusicBee and my library - Making bee-utiful music together

Sofocl

  • Sr. Member
  • ****
  • Posts: 304
Great. Thank you all! Option psychoadept the that need to.

Now for classic albums it looks like this:

And for the rest so:
Sorry for my bad English.