Author Topic: Dealing with weird library crap.  (Read 1241 times)

DaveKap

  • Newbie
  • *
  • Posts: 5
I think I broke my library with MusicBee but need some help verifying.

Look at this screenshot:
https://i.imgur.com/wbnPWk1.png

As you can see here, my inbox has all 11k of my mp3s in it after a recent rescan. However, you can see in the central window that it's completely empty with search cleared out.

The reason I did the rescan is because searching for filenames was no longer returning _all_ of the proper filenames. I confirmed this by creating a new library, rescanning the same folders, and discovering I _could_ find the missing files that searches in the other library failed to catch. I believe this has to do with the Inbox being broken (with the 11k songs but... nothing in the window.)

So what I'm wondering is, since I have no real idea how to operate the Inbox, how am I supposed to transfer the files from there over to the library? Or should I just abandon the old library... which I would rather not do as I would then lose all my radio stations, podcasts, and maybe some tagging information? I'm not sure what all I'll lose which is worse than knowing what all I would lose.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10685
Hi, welcome to the forum!

This is a puzzler, but I think we can help.  One thing to check is to open the duplicate manager in the Tools menu, and make sure they're not hidden as duplicates. It's a long shot for so many files, but still conceivable.

Beyond that, it would help to know what happened that led up to this. Did you move any of your files outside of MusicBee?
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

DaveKap

  • Newbie
  • *
  • Posts: 5
No duplicates appear to be hidden... though I did find it odd I couldn't try to find duplicates based solely on filename, it only works with tags. Am I missing how to do duplicate detection through filename?

Anyway, I have no idea how this library got to be the way it is. To be honest, I wouldn't mind removing the entire library if it weren't for the fear of losing ratings and possibly tags.

For reference, both libraries in these screenshots are after a scan of the same folders.

https://i.imgur.com/RD16Ls6.png

https://i.imgur.com/HfprIe6.png

This is the weird issue I'm having in screenshot form. To add to it, I can actually browse to those files in the library where the search fails:
https://i.imgur.com/wOq33dy.png

So what the heck?

Edit: Honestly I would accept the answer "you've corrupted your library file and have to make a new one" at this point, just checking to see if anyone else has an answer first.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10685
I'm still hoping we don't have to go the route of losing a bunch of info, as you say. Also, we can definitely give you some tips on how to make sure things are saved in the file, to protect against future instances of this.

But as a next step in troubleshooting, try browsing to one of the files using MusicBee's Computer node. Then right click and select "Send to" (but don't click on anything else, you're just looking). Is Inbox or Music Library grayed out? (Hopefully it's not Audiobooks!)

(And yeah, MusicBee does all duplicate comparisons based on metadata. You can use it to convert file paths to tags, too, though.)
Last Edit: May 27, 2019, 01:18:47 AM by psychoadept
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

DaveKap

  • Newbie
  • *
  • Posts: 5

sveakul

  • Hero Member
  • *****
  • Posts: 2034
@psychoadept:  Would it do him any good to locate MusicBeeLibrary.bak and try renaming that as *.mbl (after changing the extension on the current *.mbl of course)?  I guess I am unsure as to when this backup is actually made--after every run of MusicBee, or only when the user makes a change to the library?

redwing

  • Guest
I don't know what version of MB you're running but showing a wrong number for inbox node is a bug that's fixed a while ago.
So I'd suggest updating to the latest v3.3 version first to see if that makes any differences (but you can't apply the patch to the Windows Store version).

https://getmusicbee.com/patches/MusicBee33_Patched.zip (unzip and overwrite existing files in your MusicBee program folder)

@psychoadept:  Would it do him any good to locate MusicBeeLibrary.bak and try renaming that as *.mbl (after changing the extension on the current *.mbl of course)?  I guess I am unsure as to when this backup is actually made--after every run of MusicBee, or only when the user makes a change to the library?

That's a good suggestion and worth to try after making a backup of the current bak & mbl files. But most times it's too late as the file was already overwritten since users tend to keep restarting MB to fix the issue.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10685
Only "Music Library" is greyed out.

redwing is right about updating, I'd forgotten that that was a bug.

In any case, MusicBee thinks the track is in the library, so that's probably a good sign. What happens if you choose "Search > Locate in Library" from the right click menu?
Last Edit: May 28, 2019, 06:38:48 AM by psychoadept
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

DaveKap

  • Newbie
  • *
  • Posts: 5
Yeah I fixed the inbox thing by updated to 3.3 before I made my second post, which is why those screenshots no longer show the fake number in the inbox.

If I right click on the track in question and try to Search > Locate in Library, that option is greyed out.

And yes, of course I have restarted MB multiple times.

redwing

  • Guest
Are you saying the file shows both Send to> Music Library and Search> Locate in Library greyed out?
Also Send to> File Rescan makes no differences?
If so, try sending it to inbox and then send back to library.

DaveKap

  • Newbie
  • *
  • Posts: 5
Are you saying the file shows both Send to> Music Library and Search> Locate in Library greyed out?
Also Send to> File Rescan makes no differences?
If so, try sending it to inbox and then send back to library.
File rescan fixed it. I guess I'll need to rescan my entire library then. Oh well!

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10685
File rescan fixed it. I guess I'll need to rescan my entire library then. Oh well!

Glad something worked! Hopefully the scan is once-and-done.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)