Author Topic: PlayCount doesn't sort properly in Track View  (Read 113 times)

phoresy

  • Newbie
  • *
  • Posts: 17
I have a auto-playlist (Top 25 Most Played) with tracks in it that have a PlayCount of :

14
3
2

When I add PlayCount as a column header in the track view and click on it so the arrow is up, it sorts the list in this order:

14
2
3

When I click so the arrow is down it sorts in this order:

3
2
14

If I set a custom sorting option of PlayCount, ascending and select this as the Sort By selection, it sorts in the proper order:

2
3
14

So the bug is in the action that happens when the user clicks on the PlayCount header in the track view.

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 4290
This has been discussed before. It is not a bug. MB is using ASCII sorting instead of true numerical sorting. It appears in a few places and Steven has stated that it won't be addressed. You might try adding your comments to this thread https://getmusicbee.com/forum/index.php?topic=19870.msg118576#msg118576
Download the latest MusicBee v3.3 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

frankz

  • Hero Member
  • *****
  • Posts: 1270
FYI I'm not seeing this at all.  My play count columns sort as numbers.  AFAIK only strings should have the ASCII problem.  Numbers should sort as numbers.

Go to Edit->Edit Preferences->Tags(2)...Configure Fields and make sure Play Count has a type of Number.  Don't know how to fix it if it doesn't, though.


Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 29147
I am unable to reproduce the behaviour described ie. play count is always sorting numerically. Its possible an older version of MB might have had this issue