Author Topic: MusicBee keeps starting up on the same song  (Read 1945 times)

dirtee

  • Jr. Member
  • **
  • Posts: 58
Hello,

I'm new to the forum but had to come here because I haven't been able to fix my problem!
Formatted my laptop so I had to re-install MusicBee and managed to get my whole library and playlists back without a hitch. But every time I open MusicBee, it opens to the same song, and when I check the "resume position" in the player options in Preferences, and apply/save it, it doesn't save it because when I close and reopen MusicBee, it's back to the same song and settings.

Can anyone help me?
I'm on MusicBee version 3.2.6827 apparently!

Thanks

Freddy Barker

  • Sr. Member
  • ****
  • Posts: 748
  • 🎧 MB 3.4.7628P
Hello,

I'm new to the forum but had to come here because I haven't been able to fix my problem!
Formatted my laptop so I had to re-install MusicBee and managed to get my whole library and playlists back without a hitch. But every time I open MusicBee, it opens to the same song, and when I check the "resume position" in the player options in Preferences, and apply/save it, it doesn't save it because when I close and reopen MusicBee, it's back to the same song and settings.

Can anyone help me?
I'm on MusicBee version 3.2.6827 apparently!

Thanks
Maybe you could check in "MusicBee3Settings.ini" (Help / Support / View Settings File) and using Notepad, search (Ctrl+F) for "resume" should resemble...
Code
<PlayerStartupResumePrevious>false</PlayerStartupResumePrevious>
<PlayerStartupResumePosition>false</PlayerStartupResumePosition>

That should be displayed if - Preferences / Player / on startup: has 'do nothing' radio button checked..
Last Edit: March 11, 2019, 07:19:36 PM by Freddy Barker

dirtee

  • Jr. Member
  • **
  • Posts: 58
Hey,

Thanks for replying.
Those two lines are indeed there. But where do I go from here to fixing the problem, do you know?

dirtee

  • Jr. Member
  • **
  • Posts: 58

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34391
are any of your settings saving after restart? It sounds like you dont have write permission to the settings folder eg. try running MB as an admin to see if it makes any difference

dirtee

  • Jr. Member
  • **
  • Posts: 58
The settings were not saving on restart!
But after setting the shortcut to "Run as Administrator", it's worked! Thank you Steven!
One last question though, everytime I open it now, it brings up the pop screen where I have to allow the program to be run as administrator. Is there a factory setting I can change for that?

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34391
your windows user id doesnt have access to the MusicBee settings folder:
C:\Users\<your id>\AppData\Roaming\MusicBee
and that will need to be corrected. If you dont know how to using windows explorer, you best ask on a windows support forum

Also, you should update to the latest version on the downloads page - it wont help with this issue, bit could address other issues you might have