Author Topic: Wifi android device synching  (Read 36443 times)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30823
reverse sync matches files using the expected filename that a MusicBee library file would expect to sync to on the device based on the naming template used.
If a file was renamed directly on the device; or a change was made to the naming tags on the MusicBee library side and that change didnt get synched for some reason then there will be unmatched files residing on the device that cant be matched to the MusicBee library

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 9310
Nothing should be changing on my device, MusicBee is the only program that changes those files. But digging deeper, I did find out that I had two extra profiles under "Devices", both with generic settings. I deleted those, hopefully that will help. (Not even sure how they were created in the first place!)
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.3)
(Unzip and overwrite existing program files)

SkyZippr

  • Jr. Member
  • **
  • Posts: 98
I had to do a fresh install of Wifi app, and it fails to locate the server.
I installed the Wifi app, did a wired sync, disconnected the phone from PC, then ran the Wifi app. The error log goes:
Quote
2019-11-23: MHA-L29; 9; 1.1.2
11:56:31: locate: search=10.165.1.
11:56:31: locate: exclude=228
My phone's IP is 10.165.1.229 and my PC is currently 10.165.2.98. Both are on DHCP so may change periodically, which I'm unable to control.
Are there any workaround?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30823
Are there any workaround?
I dont have enough knowledge of socket handling in network environments to help so you are probably best using another app.

Any developer reading this and wants to help, I am very happy to make the plugin code available

SkyZippr

  • Jr. Member
  • **
  • Posts: 98
Steven, thank you for all the efforts. As a temporary solution, I'll probably wait a few days till both are on the same subnet.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30823
I dont have enough knowledge of socket handling in network environments to help so you are probably best using another app.

Any developer reading this and wants to help, I am very happy to make the plugin code available
I have added the Android app code to github

https://github.com/mayallst/MusicBeeWifiSync

vpsaxman

  • Full Member
  • ***
  • Posts: 197
Nothing should be changing on my device, MusicBee is the only program that changes those files. But digging deeper, I did find out that I had two extra profiles under "Devices", both with generic settings. I deleted those, hopefully that will help. (Not even sure how they were created in the first place!)


reverse sync matches files using the expected filename that a MusicBee library file would expect to sync to on the device based on the naming template used.
If a file was renamed directly on the device; or a change was made to the naming tags on the MusicBee library side and that change didnt get synched for some reason then there will be unmatched files residing on the device that cant be matched to the MusicBee library

Just like psychoadept said, nothing should be changed on the device. And the mismatch issues happen right after I finish syncing so it's not related to a change in musicbee either. Could it be related to the "Scoped storage" feature of Android 10? Filename length maybe?

I tried a few sync options including "preserve folders and filenames", no conversion, no artwork or lyrics embedding, and all of these at the same time to no avail. It seems like not all files are mismatched but I can't decipher a pattern.

Also @psychoadept: I too had duplicate profiles in Edit -> Edit preferences -> Devices but unfortunately deleting them did not fix the issue.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30823
could you both run this debug version and send me a zip of the error log file from musicbee itself after attempting a sync - it might be quite large

https://www.mediafire.com/file/v67ib99g10r4g27/MusicBeeDebugReverseSync.zip/file
unzip and replace musicbee.exe

Cameron

  • Newbie
  • *
  • Posts: 16
I am having an issue using wifi sync where new files are added without tags to my phone, but if I connect it via USB, remove the file and run the sync from my PC, the file transfers correctly, with tags. Is anyone else experiencing this issue?

Thanks

Cameron

vpsaxman

  • Full Member
  • ***
  • Posts: 197
could you both run this debug version and send me a zip of the error log file from musicbee itself after attempting a sync - it might be quite large

https://www.mediafire.com/file/v67ib99g10r4g27/MusicBeeDebugReverseSync.zip/file
unzip and replace musicbee.exe

Sent you a PM with the debug log. Sorry it took so long. Thanks!

SkyZippr

  • Jr. Member
  • **
  • Posts: 98
I'm running Musicbee Wifi app on a SONY ZX507 (an Android DAP), and I'd get this error:
Quote
Unable to retrieve statistics from GoneMad player. The unlocked version of GoneMad is required, otherwise the the GoneMad error log.
I do have unlocked version of GoneMad, and there's nothing recorded on GoneMad's error log.

Strangely though, if I restart the device and immediately run Wifi app, it would sync normally.
I play music on flight mode when I'm out in order to save battery, then come home to connect to Wifi before attempting a sync. Not sure if this has anything to do with the error though...

It's more likely that the problem is on DAP's side, but in case anyone else is having the same problem (I remember seeing one in this thread), try again after restarting your device.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30823
I'm running Musicbee Wifi app on a SONY ZX507 (an Android DAP), and I'd get this error:
Quote
Unable to retrieve statistics from GoneMad player. The unlocked version of GoneMad is required, otherwise the the GoneMad error log.
I do have unlocked version of GoneMad, and there's nothing recorded on GoneMad's error log.
That error can occur when GoneMad fails to generate the stats.xml file. It can happen when one of the filenames has an invalid character in it. It has been reported to the GoneMad developer but he didnt seem to be interested to look into it further.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30823
Sent you a PM with the debug log. Sorry it took so long. Thanks!
In your case, some of the filesnames gonemad is returning include an extra "primary/" prefix and hence not matched in MB. Can you confirm you whether you have given me your google play email so you can be added to the alpha track for the android app and that you are happy to run a debug version so i can confirm what is going on

SkyZippr

  • Jr. Member
  • **
  • Posts: 98
I'm running Musicbee Wifi app on a SONY ZX507 (an Android DAP), and I'd get this error:
Quote
Unable to retrieve statistics from GoneMad player. The unlocked version of GoneMad is required, otherwise the the GoneMad error log.
I do have unlocked version of GoneMad, and there's nothing recorded on GoneMad's error log.
That error can occur when GoneMad fails to generate the stats.xml file. It can happen when one of the filenames has an invalid character in it. It has been reported to the GoneMad developer but he didnt seem to be interested to look into it further.
Thanks Steven, but I think the issue I'm having is more complicated. The stats.xml file is indeed in the gmmp folder.
I've also noticed that, somehow GMMP is unable to read the tags of the files transferred via wifi sync, and they all show up as 'Unknown Artist' with empty tags. What's even stranger is, the stock player app of SONY ZX507 (aka Walkman app) reads the tags of those files without any problem. Files transferred via wired sync seem to be handled with no problem by both apps mentioned.
I suspect that maybe there are some hidden restriction of storage handling or something in SONY ZX507, although it's supposed to be pure Android unlike Fiio's. Maybe wifi app is unable to properly write something, or maybe GMMP is unable to properly read something.

I've never experienced anything like this with my smartphone, so I guess this is a device-specific issue. I'll try contacting SONY's customer support.

HerrMerkt

  • Newbie
  • *
  • Posts: 8
In the last few days, I was unable to start MusicBee Wifi Sync on my Galaxy S10. That's a bit puzzling because Wifi Sync works on my Galaxy Tab without any problems. Are there any known issues with Wifi Sync and the Galaxy S10?

I have already deleted the profile of the Galaxy S10 in my MusicBee settings as well as the appdata on the Galaxy S10 several times. Nothing helped.

Some more information for troubleshooting:
- I want to sync to a micro SD card in the Galaxy S10 (400GB). I have tested syncing the files to the phone storage and this seemed to work. However, this is not an option because I do not have enough storage on the phone.
- When I want to start syncing in the app and hit the sync button, nothing happens. There is no error message or whatsoever; however, the syncing process doesn't start.