Author Topic: MusicBee's shows lyrics without line breaks  (Read 2914 times)

EGOlein

  • Jr. Member
  • **
  • Posts: 25
Hi guys,

I just loaded and installed MusicBee to switch from iTunes. Most things work well and even better than Apples software. However, there is one thing which is really annoying to me: All my files are maintained and tagged with iTunes. It works fine for MusicBee, everything is also in MusicBee. Only lyrics are shown without line breaks in MusicBee even though they exist. :'(

To give you a better understanding, I have posted both, how MusicBee shows lyrics an how iTunes does:


MusicBee


iTunes

It is the same file both music players have access to. If I copy the lyrics from iTunes to MusicBee and save the file with it, the lyrics are shown correctly with line breaks in iTunes and MusicBee. However, I do not want to copy lyrics for thousends of music files. Automatic lyrics are no solution to me since they are mostly not correct (that's why I maintain own lyrics).

Has anybody an idea how I can make MusicBee to show the lyrics correctly?

Greetings
EGOlein
Last Edit: November 05, 2018, 04:03:44 PM by EGOlein


EGOlein

  • Jr. Member
  • **
  • Posts: 25
Hi redwing,

That works great. Thanks a lot for the link and your quick help. :D

Greetings
EGOlein

EGOlein

  • Jr. Member
  • **
  • Posts: 25
Hi there, it's me again,

Unfortunately there has been occured another Problem: In some files MusicBee does not show the embedded lyrics but lyrics from the Internet (e.g. AstraLyrics). In iTunes the embedded lyrics are shown.

I added lyrics automatically for songs without lyrics and perhaps MusicBee did not devide properly between missing lyrics and files with lyrics (or the error was sitting in front of the screeen). However, the correct lyrics are still in the mp3 files but not considered / shown in MusicBee. I tried to reload / reread the tags but nothing happened.

How can I make MusicBee to show (or reload) the tagged lyrics from the file instead of internet lyrics.

Greetings
EGOlein

redwing

  • Guest
You can disable auto-lyrics feature in Preferences> Tags (2).
Also verify with tag inspector, which can be launched from tag editor, if the file has lyrics tag.

EGOlein

  • Jr. Member
  • **
  • Posts: 25
Hallo,

auto-lyrics are disabled. But within the tag inspector I found that there are two different song lyrics:



The USLT/deu is the one which is obviousy coming from the internet (AstraLyrics), the USLT/eng is the on I maintained manually. Can I delete the USTL/deu from all songs?

Greetings
EGOlein

redwing

  • Guest
If you are sure MB auto re-added lyrics to tracks that already have lyrics, then file a bug report. It could be about language descriptor appended to lyrics tag but I'm not sure.

And try deleting one lyrics for a test file to see what happens.

EGOlein

  • Jr. Member
  • **
  • Posts: 25
I did already delete the USLT/deu lyrics from the exemple file and MusicBee displayed the USLT/eng lyrics (my manually maintained lyrics) afterwards. Furthermore, I have searched other files with two lyrics and from that sample I took all USLT/deu lyrics have a reference to a lyrics service (such as AstraLyrics, lyricskeeper). Therefore, I am looking for a way to find and delete all USLT/deu lyrics from all my files. Is there a chance to make this automatically or do I have to do it manually?

Greetings
EGOlein

redwing

  • Guest
You could use Tools> Tagging Tools> Remove Tags command or tag inspector if selected files are all the same format.

EGOlein

  • Jr. Member
  • **
  • Posts: 25
:D  :)  :D  ::)  ;D  :D  ;)  ::)

Great! It works (I just tested it with a few files but that test was working fine). Thanks a lot for your help. It saved hours of hours of boring and stupid work!

Greetings
EGOlein

redwing

  • Guest
Now if you re-enable auto-lyrics and play a track with USTL/eng tag, does MB auto-add USTL/deu tag to that file?


EGOlein

  • Jr. Member
  • **
  • Posts: 25
Now if you re-enable auto-lyrics and play a track with USTL/eng tag, does MB auto-add USTL/deu tag to that file?
Hi, I have recently deleted all USTL/* tags except USTL/eng tags. After that I let MB search lyrics for all songs without lyrics and they are stored as USTL/eng. Now everything seems to work.

Thanks a lot for your help.

EGOlein