Author Topic: Elemental  (Read 8066 times)

alec.tron

  • Hero Member
  • *****
  • Posts: 655
Haha, please be kind to my delicate skin ;-)

I'll try to... dialed it back to useable levels, and re-using your orange:

Code
<?xml version="1.0" encoding="utf-8"?>
<root dependsOn="Elemental.xmlc">
<colours id="Default">
 <element id="Player.Wavebar" bg="54,54,54" fg="68,68,68" fg2="111,88,66" />
 <element id="Player.Wavebar.Inner" fg="42,42,42" fg2="245,124,3" />
</colours>
</root>

That'll do for now for me.
c.

alec.tron

  • Hero Member
  • *****
  • Posts: 655
One oddity still - the Playlist Explorer, which I use heavily, has a slightly different background grey, i.e. 54,54,54, similar to the "Library Explorer" which pops out from left on hover. But, all other Music Explorer panels use a 48, 48, 48 grey....
I can't find a Playlist Explorer panel explicitly mentioned in the sample xml... any idea how/where the Playlist Explorer panel bg setting would live ?

Cheers.
c.

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3967
I can't find a Playlist Explorer panel explicitly mentioned in the sample xml... any idea how/where the Playlist Explorer panel bg setting would live ?
Are you using a colour piker on the Sample Skin?
That would tell you it uses the same colour as the library explorer panel:
<element id="Panel.Body.Default"

watdub

  • Jr. Member
  • **
  • Posts: 30
Thanks for this skin.  The album covers/photos really 'pop' (albums and tracks view).  
I've just 'wasted' an half hour scrolling up and down through the album photos reconnecting album covers with old memories  :)

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3967
I've just 'wasted' an half hour scrolling up and down through the album photos reconnecting album covers with old memories  :)

That's half an hour well-spent.
Men in chairs smoking cigars or scrolling albumart in MusicBee don't cause wars...

Johan_A_M

  • Jr. Member
  • **
  • Posts: 50
This is a fantastic skin, thank you Hiccup, I really love it! One question (sorry, I can't do a screenshot right now): When tagging multiple files with different e.g. genres, the dropdown menu does not have any visual checkboxes. Instead, I think the text changes color on mouse-over. Is this by design or a minor glitch?

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3967
the dropdown menu does not have any visual checkboxes.

What location is this?
Docked tag editor? Floating tag editor, sidebar editor? Somewhere else maybe?

Johan_A_M

  • Jr. Member
  • **
  • Posts: 50
the dropdown menu does not have any visual checkboxes.

What location is this?
Docked tag editor? Floating tag editor, sidebar editor? Somewhere else maybe?

It's at least in both the vertical tag editor as well as the Edit window. It's when you see "Mixed" in a tag and click the arrow to pick one or several. I suspect this is by design, just curious. I'll make a screenshot later when I'm at the correct computer, if not for anything else then at least for future clarity.

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3967
Take your time.
My eyes are a bit tired, my display set to very low brightness/blue light, so I'm going to take a look at this with fresh eyes probably tomorrow.
Thanks for reporting.

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3967
It's when you see "Mixed" in a tag and click the arrow to pick one or several.

Ah yes, I see what you mean.
I'll see if I can change it, but it might be a bit difficult because it shares the colour of similar elements at other locations.
And since it is a low contrast grey skin, and small deviations in brightness is pretty much the only thing I can toy with here, this might require a new colouring element that does not yet exist.
I'll see what I can figure out one of these days.

Johan_A_M

  • Jr. Member
  • **
  • Posts: 50
It's when you see "Mixed" in a tag and click the arrow to pick one or several.

Ah yes, I see what you mean.
I'll see if I can change it, but it might be a bit difficult because it shares the colour of similar elements at other locations.
And since it is a low contrast grey skin, and small deviations in brightness is pretty much the only thing I can toy with here, this might require a new colouring element that does not yet exist.
I'll see what I can figure out one of these days.

Don't put too much time into this, I was mostly curious :)

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3967
Updated.

- Fixed a bug when having the player bar on top and tabs in the caption bar.
- Added icons for drives and devices. (they will only display with MB 3.4 which is at the moment not yet available as a stable release)

@Johan_A_M,
The issue with the invisible check-boxes has not been fixed. I've put out a skinning feature request to make it possible to hopefully address this in the future.

Johan_A_M

  • Jr. Member
  • **
  • Posts: 50
Updated.

- Fixed a bug when having the player bar on top and tabs in the caption bar.
- Added icons for drives and devices. (they will only display with MB 3.4 which is at the moment not yet available as a stable release)

@Johan_A_M,
The issue with the invisible check-boxes has not been fixed. I've put out a skinning feature request to make it possible to hopefully address this in the future.

Great news, I still find this skin to be my absolute favourite!

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3967
Updated, minor tweaks.

Quote
The issue with the invisible check-boxes has not been fixed. I've put out a skinning feature request to make it possible to hopefully address this in the future.

This is now also fixed.
Thanks Johan_A_M for reporting.
(Note that this will only be fixed for MusicBee 3.4+ which is not yet available at this moment.)

Johan_A_M

  • Jr. Member
  • **
  • Posts: 50
This is now also fixed.
Thanks Johan_A_M for reporting.
(Note that this will only be fixed for MusicBee 3.4+ which is not yet available at this moment.)

Great, thanks!