Author Topic: Problems syncing to root of virtual device  (Read 1381 times)

romney_yw

  • Jr. Member
  • **
  • Posts: 34
I'm experiencing problems when attempting to sync to the root of a virtual device. I'm not interested in Podcasts, Audiobooks or Video, so I just want my music files synced to the root of the device. The files are already organised by <Album Artist>/<Album>/<Track> <Title> on my PC, so I'm trying to use the 'preserve folders and filenames' option in the device settings (accessed via Preferences - Devices - <select device> - Configure - Settings).

The storage path for my virtual device is \\RASPI001\PiMusic\ I have tried a variety of different path entries for music files - some of which are based on other posts on this subject elsewhere on this forum. I've tried leaving the music files box empty, and also  specifying . \ or * for the path.

When I attempt to synchronise the device, I frequently get an error message "The storage folder '\\RASPI001\PiMusic\#\' no longer exists and may need to be changed in the device synch preferences". The # is something that MusicBee appears to have invented - it is not a character I have entered manually into the storage path.

When I check the settings from the device synchronisation page, the path shown for Music files does not necessarily match the value which I believe I saved via Preferences - Devices - Configure - Settings. The sync results obtained vary according to the actual path string entered, and I have attempted to summarise my observations below.

Devices - Configure              Error Message?        Synchronise - Settings          Sync action
<empty>                            Yes                          *                                        Fails with repeat error message
.                                         Yes                          *                                        Fails with repeat error message
\                                         Yes                          Virtual Device (PiMusic)\*     Fails with repeat error message
*                                        Yes                          #\*                                     Fails with repeat error message

If I change the music path directly in Synchronise - Settings, the following behaviour is observed
<empty>                  sync proceeds, but files are copied/renamed to \Music\ in the virtual device
.                               sync proceeds, but files are copied/renamed to \Music\ in the virtual device
\                               error message - the storage folder 'Virtual Device (PiMusic)\' no longer exists
*                              sync proceeds, but files are copied/renamed to \#\Music\ in the virtual device

This seems to me to be a bug. The path settings do not appear to be consistent between Preferences - Devices - Configure - Settings and Synchronise - Settings, and in no case does MusicBee actually synchronise or attempt to synchronise to the desired target folder i.e. the root of the virtual device.

I could probably work around this by accepting an additional (and unnecessary?) \Music\ folder on my virtual device, but I don't believe there should be any reason why I can't sync my organised music folders to the root of the device. I would be more than happy to provide any additional details which may be required to help debug this issue, and also to carry out any further investigation which may be useful.