Author Topic: Is it only me or it's a bug? [FIXED]  (Read 1232 times)

emmecì

  • Newbie
  • *
  • Posts: 17
I really don't know if it's only me or the latest build, but if I choose <Bit Depth> tag on info track, the return value is always empty - other values (replaygain etc) are all ok

build 3.2.6727
*only on APE audio files*
https://i.imgur.com/oNCKEPR.png

EDIT: fixed by Steven --- that was fast 8)
Download latest build: 3.2.6728
http://musicbee.niblseed.com/V3_2/MusicBee32_Patched.zip
Last Edit: June 03, 2018, 07:53:09 PM by emmecì

sveakul

  • Sr. Member
  • ****
  • Posts: 2459
Bit depth will always show as empty if the file is lossy (mp3, aac, etc) because they have no set bit depth ("floating").  Lossless files like FLAC will show a value (16, 24, etc.).  If you'd rather have an indicator of your choosing show up for lossy instead of a blank (I use "FL" for example), follow the instructions here:

https://getmusicbee.com/forum/index.php?topic=24661.msg143556#msg143556

If you're not talking about "Track Information" fields, but actual metadata tags, check this thread:

https://getmusicbee.com/forum/index.php?topic=25486.0
Last Edit: June 01, 2018, 05:55:39 PM by sveakul

emmecì

  • Newbie
  • *
  • Posts: 17
First, thanks for the help.
I dont quite catch... if the file is loseless (ie: monkey audio 24 bit), it will always show blank. Only lossy shows valid value.
This <bit depth> for loseless files will reamin emply and will be no support by the author, isnt it?

frankz

  • Sr. Member
  • ****
  • Posts: 3876
It's the opposite. Lossless files show bit depth because it is a fixed value.  Lossy files don't technically have a bit depth, as it is variable, so they show nothing.

emmecì

  • Newbie
  • *
  • Posts: 17
That is indeed weird...
I rescan my library, downloaded the latest build 3.2.6727 and this is what I see

https://imgur.com/a/4K10K9w


sveakul

  • Sr. Member
  • ****
  • Posts: 2459
Well blow me down (was it Popeye used to say that?).. when I saw your pic was showing APE files, I tried one of the few APE format tracks I have and guess what--a "blank" (or "FL" in my case) bit depth shows in my Now Playing track information. Switch to FLAC, and 16 or 24 show just fine.  Apparently the APE format was missed when this display parameter was added?  Over to Steven now I think!