Author Topic: Music Explorer splitting albums by track date  (Read 1812 times)

nsd3

  • Newbie
  • *
  • Posts: 7
I'm brand new to MusicBee, so I'm still finding my around all of its features.  So far so good, but there's one element of the application I can't seem to find out how to correct.  If I'm in Music Explorer view, I'm finding that it displays the same album multiple times, if the Year tag is different on a track by track basis.

By way of example, if an album contains 10 tracks, nine of which have 2016 as the year tag, and one track has 2017 as its year tag, the album displays twice.  One instance shows nine tracks, the other shows one track.  Even if all other album (shared) track data is the same.  It's most noticeable whenever there's a "greatest hits/best of" type of album.

Is there any way to stop Music Explorer displaying multiple copies of the same album?   Basically ignore the track year tag and display the album based on the album name instead?

Thanks in advance,

Steve

boroda

  • Hero Member
  • *****
  • Posts: 4740

nsd3

  • Newbie
  • *
  • Posts: 7
I tried that with no success.  My grouping settings are:

Preferences>Sorting/Grouping

The following fields define an album
Album Artist>Album Name

As my albums each have their own folder, I tried the option "Files for each folder are organised in their own folder"

Neither option works.  I restarted the app after each change just in case that was needed, but to no effect.


Steve

nsd3

  • Newbie
  • *
  • Posts: 7
I've found the solution.  It wasn't the sorting/grouping causing the problem at all.  When in Music Explorer view, right click on the Artist Information bar (above the artist name in the main panel) and select Sort albums>By title.

Mine was set to sort by year.  Job done!

Steve