Author Topic: Keybord navigation problem with certain tabs  (Read 1465 times)

Skinjob

  • Jr. Member
  • **
  • Posts: 44
I recently got a FLIRC (a little USB device that receives IR signals and turns them into keystrokes) for my music PC, which is hooked up to my TV & stereo.  I've been using the FLIRC to let me control MB with my Logitech Harmony 650.  I've programmed the FLIRC to send Ctrl+Tab and Ctrl+Shift+Tab when corresponding buttons are pressed on the Harmony so I can change tabs in MB with the Harmony.  In general it works, but I noticed one problem with certain tabs in MB.

I have 5 tabs pinned in MB in the following order: Music, Playlists, Now Playing, Music Explorer, Inbox.  Ctrl+Tab and Shift+Ctrl+Tab will switch forward and backwards through the tabs as expected.  However, once Now Playing or Music Explorer has the focus, keyboard tab navigation stops working.  I have to use the mouse to focus some other tab and then it will work again (as long as I don't go to Now Playing or Music Explorer).

I understand this is a most likely a non-issue for 99.9% of users who use a mouse, but it would sure be nice if this worked correctly.  I'd hardly have to touch a keyboard/mouse at all with MB.

One other minor related issue.  It would be nice if when closing a tab, the previously active tab was focused instead of always going to the rightmost tab.  I have another button on the harmony programmed to toggle the visualizer, which is where I notice this issue.  If I was on the Music tab and launch the visualizer, when I close it I'm on Inbox instead of going back to Music.  Again, super minor issue, but it forces some unnecessary navigation that makes it easy to run into the above problem.

CritterMan

  • Hero Member
  • *****
  • Posts: 557
  • Now with FiiO M11!
I can reproduce this issue using my keyboard on version 3.2.6650. It affects the Now Playing tab and all device tabs. Music, Playlists, and Inbox tabs are unaffected.

Home Desk ~ MB 3.3 Portable • Questyle CMA400i (ASIO) • Sennheiser HD 660S (balanced) / Audeze EL-8 Closed Back / Fostex TR-X00 Ebony • Teac AI-101DA • Jamo C93 + Dayton Audio SUB-1000
Work Desk ~ MB 3.3 Portable / Tidal • SMSL SU-8 v2 • Nobsound NS-05P • THX AAA 789 • Sennheiser HD 58X (balanced)
OTG ~ FiiO M11 • Audiofly AF180 / B&O H6

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32914

CritterMan

  • Hero Member
  • *****
  • Posts: 557
  • Now with FiiO M11!
Ctrl+Shift+Tab is still getting stuck on device tabs. Once stuck, even Ctrl+Tab does not work until a different type of tab is selected by mouse.
Home Desk ~ MB 3.3 Portable • Questyle CMA400i (ASIO) • Sennheiser HD 660S (balanced) / Audeze EL-8 Closed Back / Fostex TR-X00 Ebony • Teac AI-101DA • Jamo C93 + Dayton Audio SUB-1000
Work Desk ~ MB 3.3 Portable / Tidal • SMSL SU-8 v2 • Nobsound NS-05P • THX AAA 789 • Sennheiser HD 58X (balanced)
OTG ~ FiiO M11 • Audiofly AF180 / B&O H6

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32914
Ctrl+Shift+Tab is still getting stuck on device tabs. Once stuck, even Ctrl+Tab does not work until a different type of tab is selected by mouse.
I am afraid I cant reproduce that and I see no reason for it to happen, so unless new light is shed on the issue it will remain unsolved

CritterMan

  • Hero Member
  • *****
  • Posts: 557
  • Now with FiiO M11!
Well, I can't reproduce it anymore either after updating to 3.2.6651. That was the only change, I had restarted MB several times trying to troubleshoot as well. I haven't even rebooted by rig, so we'll chalk that up to a fluke. I'm not the OP, but I'm calling this solved.

Home Desk ~ MB 3.3 Portable • Questyle CMA400i (ASIO) • Sennheiser HD 660S (balanced) / Audeze EL-8 Closed Back / Fostex TR-X00 Ebony • Teac AI-101DA • Jamo C93 + Dayton Audio SUB-1000
Work Desk ~ MB 3.3 Portable / Tidal • SMSL SU-8 v2 • Nobsound NS-05P • THX AAA 789 • Sennheiser HD 58X (balanced)
OTG ~ FiiO M11 • Audiofly AF180 / B&O H6

Skinjob

  • Jr. Member
  • **
  • Posts: 44
Thanks to Steven and CritterMan for fixing this one!  Much appreciated.

Skinjob

  • Jr. Member
  • **
  • Posts: 44
I can confirm this is working correctly for me in 3.2.6651.  Thanks again.