Author Topic: Unable to get disc numbers to appear as a sub-heading when using 3.2 beta  (Read 3014 times)

zigzag10

  • Jr. Member
  • **
  • Posts: 60
I really like seeing a "Disc 1, Disc 2 etc" sub-heading for multi-disc albums.  I’ve assigned $If(<Disc Count>>1,"Disc "<Disc#>,) to a virtual tag and I’ve selected this tag as a sub-group heading  -  following the instructions set out here: https://getmusicbee.com/forum/index.php?topic=15094.0.  But I can no longer find the ‘Expanded Panel Settings’ in 3.2 beta and I can’t get the multi-disc sub heading to display when I’m using ‘Album Covers’ to view my collection.  Is there anything that can be done to get this to work?

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8165
Try this as the virtual tag. It's what I use and it works as expected:
$If(<Disc Count>>1,$IsNull(<Disc#>,Null,"Disc "<Disc#>),)

NB: It will not show a disc number if there is only one disc in the set.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

zigzag10

  • Jr. Member
  • **
  • Posts: 60
Try this as the virtual tag. It's what I use and it works as expected:
$If(<Disc Count>>1,$IsNull(<Disc#>,Null,"Disc "<Disc#>),)

NB: It will not show a disc number if there is only one disc in the set.

Thanks Phred.  That's a more sophisticated formula for multi-disc albums, which I will glady start using.  I have to two installs of mb on my pc, a full install and a portable running mb 3.2 beta.  Your code works on the full install without issues, but as was the case with what I was using earlier, isn't displayed on the portable running 3.2 beta when ‘Album Covers’ is selected to view a collection.  Having said that, it does work on 3.2 beta when using 'Album and Tracks'.  Starting to think this may be a minor bug...
Last Edit: January 08, 2018, 09:06:09 PM by zigzag10

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8165
Your code works on the full install without issues, but as was the case with what I was using earlier, isn't displayed on the portable running 3.2 beta when ‘Album Covers’ is selected to view a collection.
I doubt it's a bug as I'm using 3.2 portable and it's working fine in Artwork view:

The only think I can think of as to why it's not working is that you don't have the total number of discs set.
Download the latest MusicBee v3.5 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here.

zigzag10

  • Jr. Member
  • **
  • Posts: 60
Your code works on the full install without issues, but as was the case with what I was using earlier, isn't displayed on the portable running 3.2 beta when ‘Album Covers’ is selected to view a collection.
I doubt it's a bug as I'm using 3.2 portable and it's working fine in Artwork view:

Thanks for getting back to me again Phred. I've got say I'm stumped on this: I've definitely set the 'total number of discs set' and when ‘Album Covers’ view mode is selected the disc number isn't displayed on my portable install of 3.2 beta, yet when ‘Album Covers’ is selected in 3.1 it does. And I reinstalled 3.2 beta portable and the issue still occurs.  (The images below may help in illustrating what I'm referring to!)

'Album Cover' Mode -No Disc Number:


'Album and Tracks' - Disc Number is displayed

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3776
  • MB Version: 3.5.8367 P
Make sure your virtual tag for the disc# is in the sub-grouping header field for the 'Album Covers' view under:
Customise Panel...>  click to show settings>  sub-grouping header:
MusicBee and my library - Making bee-utiful music together

zigzag10

  • Jr. Member
  • **
  • Posts: 60
Make sure your virtual tag for the disc# is in the sub-grouping header field for the 'Album Covers' view under:
Customise Panel...>  click to show settings>  sub-grouping header:

Thanks for the suggestion Bee-liever.  The approach you outlined does work for 3.1, but only via the 'Configure Expanded Panel' button/dialog box.  As far as I can see the the 'Configure Expanded Panel' no longer features in the cuurent version of 3.2 beta and, unless I'm missing something, there isn't an alternative approach to assigning a sub-gruping header for 'Album Covers'.

redwing

  • Guest

zigzag10

  • Jr. Member
  • **
  • Posts: 60
It's there. As Bee-liever said, find "click to show settings" option.

At last I've grasped the new approach to bringing up what was previously refered to as the 'Configure Expanded Panel'!  Thanks v much redwing, Bee-liever and Phred The image below may assist others: