Author Topic: Randomly play all tracks in a library  (Read 4858 times)

cynflux

  • Jr. Member
  • **
  • Posts: 76
What are the correct settings to play all songs in a library without the same artist and same songs playing twice in a row? There are 49 total tracks with 15 artists. I have tried shuffle, auto dj, etc. Not have any luck with any of those. Thank you in advance for your help.

redwing

  • Guest
Did you try setting a value for "gap before the same artist can appear" option with Auto-DJ?

cynflux

  • Jr. Member
  • **
  • Posts: 76
I have. I can't seem to find the correct value. Is there some type of formula or calculation that needs to be used to done to determine the correct  gap amount?

redwing

  • Guest
I guess it won't be easy especially if most songs are only by a few artists. To randomize it, I think you need to get the library (playlist) more even in the number of songs per artist.

cynflux

  • Jr. Member
  • **
  • Posts: 76
Thank you for the suggestion.Would a play count filter help?

cynflux

  • Jr. Member
  • **
  • Posts: 76
I guess it won't be easy especially if most songs are only by a few artists. To randomize it, I think you need to get the library (playlist) more even in the number of songs per artist.

I think I may have found a workaround.

In Auto-DJ, I click the Start DJ button which lists the tracks in the Upcoming Tracks section.
I have set 'gap before the same artist can repeat:' as 1.
I select all the tracks and add them to a new playlist.
I right-click on the new playlist and select List > Remove Duplicates.
The artists that have the most songs seem to placed further down in the playlist, while the ones with the fewest are more towards the top.
The same artist doesn't seem to repeat back to back, but skips 1 towards the end of the playlist.


elibroftw

  • Newbie
  • *
  • Posts: 1
Found out how to do it  8) (All tracks once, artists may repeat)
1. Make sure shuffle is On
2. Make left side-bar show Folder Names
3. Double Click All
4. Enjoy ;)

cynflux

  • Jr. Member
  • **
  • Posts: 76
Elibroftw,
Can you post a screenshot of what you are referring to?
It's been a while since I created this post and can't seem to find the items you are referring to.
Thanks in advance.

Bizy

  • Sr. Member
  • ****
  • Posts: 304
Quote
I have set 'gap before the same artist can repeat:' as 1.
Try 15.

Also:  Edit/Edit preferences/Now playing - shuffle settings
(slide to different artist)
(Or, in Auto DJ settings:  selection mode - idem, slide to different artist)
Last Edit: May 20, 2019, 02:38:40 PM by Bizy
Full installer Version 3_4_7805
Portable Editon 3_4_7805 P
OS: Windows 10 Home Edition