Author Topic: Context menu sometimes lists plugins, but other times doesn't..  (Read 1460 times)

zigzag10

  • Jr. Member
  • **
  • Posts: 60
Hi I hope someone can help.  If, when MB starts, I immediately right click an album or track, two of the plugins I've installed are listed at the bottom of the context menu that's displayed:

 

However, if I then select another album or track and right click again, these plugins aren't displayed:


 
I've no idea why this should happen.  I've noticed that if I select something other than 'music' from the navigator panel, then select 'music' again, the plugins are displayed once again on the context menu, but this isn't ideal.  Is there anything I can do to resolve this?
Last Edit: November 23, 2017, 09:46:49 AM by zigzag10

paulca

  • Newbie
  • *
  • Posts: 6
Same issue here.

Been searching the reason of this behaviour for the last 2 days.

Started to use GMT Manager to tag genre on my 1800 albums and I have to restart Musicbee after each album its not really efficient

zigzag10

  • Jr. Member
  • **
  • Posts: 60
Same issue here.

Been searching the reason of this behaviour for the last 2 days.

Started to use GMT Manager to tag genre on my 1800 albums and I have to restart Musicbee after each album its not really efficient

Thanks for coming back to me Paulca. I've just worked out that this issue is dependent on the view that's being used.  It occurs if your using 'album covers', 'artists' or a 'custom view'; but doesn't if the view is 'Tracks' or 'Album and Tracks'.  So good news of sorts 8) .  On a side note, it would be good to hear how you get on with the GMT manager plugin.  I’ve got a similar sized collection and I’m really interested in the possibility of this featuring multiple genres...
Last Edit: November 29, 2017, 09:54:50 AM by zigzag10

paulca

  • Newbie
  • *
  • Posts: 6
Hello,

I found yesterday that in my case switching view would reenable the plugin.
I have used GMT Bot to add genre, mood and occasion on ~600 albums
I noticed that Bot is only finding genres for artists so I now have many errors to correct on newly updated albums.

I restarted tagging other albums 1 by 1 as it seems only way to have reliable tagging.

redwing

  • Guest
I noticed that Bot is only finding genres for artists so I now have many errors to correct on newly updated albums.

I restarted tagging other albums 1 by 1 as it seems only way to have reliable tagging.

Why not report such an issue to the plugin thread, which will notify the plugin developer?

zigzag10

  • Jr. Member
  • **
  • Posts: 60
Another reason why MB is brilliant: I raised this as a potential bug yesterday and less than 12hrs later Steven issues a fix 8). See - https://getmusicbee.com/forum/index.php?topic=23424.msg136748#msg136748