Author Topic: Second selection clears playlist  (Read 1668 times)

diedie2

  • Jr. Member
  • **
  • Posts: 21
Hi,

I'm sorry the topic title isn't that clear, but don't how to formulate it better.

The problem I have is the following:
- Open windows explorer and go to a folder with some music in
- double click on song to play. MusicBee will start.
- double click on same song again (again in windows explorer).
- The playlist gets cleared and MB stops playing.

I can reproduce this any time. Even closing MB between step 2 & 3 does not help. Selecting another song in step 3 does NOT reproduce, it really has to be the same.
The music I used are MP3 files, don't have any other format for the moment.

I'm on Windows 10 and using MB 3.1.6466

I already check the error log file but it's as good as empty.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34406
i am not able to reproduce this so can you send me a link to your settings file (help/ support/ view settings)


Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34406

diedie2

  • Jr. Member
  • **
  • Posts: 21
As far as I can tell it seems the bug is fixed, tnx!

diedie2

  • Jr. Member
  • **
  • Posts: 21
Could it be your solution caused another bug? I'm not sure...

When I hover the panel with control-elements (previous play/pause next) while a song is playing, the pause-button changes to a stop-button. When I click on it, the song stops but stays in the playlist. Then it changes to Play, but clicking that does nothing. Also, there is no circle around the stop-button, although I use Metro-style buttons.

This only happens in the main screen, can't reproduce this in the mini-player.

redwing

  • Guest
It's a feature to make it stop rather than pause when you're holding shift (not control) key. If you keep holding the shift key, play button won't be clicked. So release it.

diedie2

  • Jr. Member
  • **
  • Posts: 21
hm, this is weird...

I've tested again and now it's working like you say. I'm pretty sure I wasn't pressing any keys on the keyboard at that time, but for now it seems OK...

sry for inconvenience  ;)