Author Topic: MusicBee is not saving tagging information  (Read 1321 times)

strayslack

  • Newbie
  • *
  • Posts: 1
Hey, so I have a pretty large music library that contains about 440 GB of music, about 40,000 files, and so on (I'm not sure if that info is related to my question or not but I figure I should give it out if it's an actual cause I wouldn't expect). Anyway, I probably have a pretty complex tagging system, where I just assign multiple genres to entire albums. So like if it's an album it could get 8+ with the same genre, EP with however many songs that has, or a single with just that one or two songs. Usually I assign 1-4 genres per album, but some I assign over 10. I don't have any genre categories in place as of now.

Anyway, I wanna keep that up, but MusicBee isn't saving any tags I make when I shut the program down and open it back up. I see that sometimes it hangs on the "Saving tags..." part on the lower left corner of the window for longer than it probably should, but the thing is, the tags are saved to the music file itself so if I use tag inspector I can just check off boxes and it'll show up on MusicBee. I just don't wanna do that every time because it really makes the organization I have set up go out the window. It just started doing this too, so for music I have imported longer than 2 months ago, the tags stay in place. Is there any solution you could think of to this?

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7725
Check to make sure your files are not 'read-only.'
And/or add MB to your anti-virus whitelist. Especially if you use Avast, which has been know to cause problems for MB users.

Also update to the latest 3.1 patch. See my sig.
Download the latest MusicBee v3.4 patch from here.
Download the latest MusicBee v3.5 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here