Author Topic: Disable Fade-In When Resuming Play  (Read 331 times)

Mike776237

  • Newbie
  • *
  • Posts: 4
If you are listening to a song and hit pause, on resume it will fade back in even with all fade options disabled.
Please fix this, thank you.

sveakul

  • Hero Member
  • *****
  • Posts: 1268
This does not happen here (WASAPI Exclusive, Event), although there is a a slight "hiccup" on resume--not a fade-in but a momentary "pop-and-resume" as opposed to an immediate resume.  What audio device output selection in MB prefs are you using, and what version of MB?  If you are using DirectSound, check the settings in Windows Mixer and any 3rd-party "audio panel" that may be influencing this.

Mike776237

  • Newbie
  • *
  • Posts: 4
It happens no matter the sound settings, though mine are WASAPI (shared) and primary sound driver. I am on version 3.3.7261.

Here is a video I just made about it. https://www.youtube.com/watch?v=stXtHqx8Kt0
The few pops you hear are from the capture, on my end it is a smooth playback with that fade in on resume, as shown


Other people seem to have had this problem in the past with no solution as well:

https://getmusicbee.com/forum/index.php?topic=13021.msg78466
https://getmusicbee.com/forum/index.php?topic=27921.msg155047

sveakul

  • Hero Member
  • *****
  • Posts: 1268
Have to wait for Steven to comment on this one.  As I said, I don't see a fade-in with all sound-effects options disabled, but there is the pause-click before the resume as opposed to a smooth immediate resume after pause.  The latter is the case with Foobar and AIMP;  as neither of those use bassmix/bass_fx.dll, perhaps part of the issue is with the bass library.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31008
its true that on resuming from pause MB fades in for 0.5 second
I have changed it so when smooth fade is unticked, the period is reduced to 0.05 second. This is to help stop glitches when resuming

https://getmusicbee.com/patches/MusicBee33_Patched.zip
unzip and replace the existing musicbee application files

Mike776237

  • Newbie
  • *
  • Posts: 4
I have changed it so when smooth fade is unticked, the period is reduced to 0.05 second.

Thank you for addressing this issue, however I believe it now does the opposite, where it will not fade on resume if the smooth fade on stop box is ticked

sveakul

  • Hero Member
  • *****
  • Posts: 1268
Thank you for addressing this issue, however I believe it now does the opposite, where it will not fade on resume if the smooth fade on stop box is ticked

Confirmed here.  Checking the "smooth fade when stopping box" (all other fading disabled) does not actually fade when stopping, but eliminates the small hiccup/pause before resume I was experiencing here since "forever" when I've had no fade options checked; now, resuming after a pause is instant, which is GREAT :)  So, the change made worked, it just needs to be freed from the need to check the smooth fade when stopping box (and any resampling that may add) to make it happen.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 31008