Author Topic: File Converters  (Read 3513 times)

zion

  • Newbie
  • *
  • Posts: 7
Everytime I select "File Converters" in the Preferences, MusicBee freezes. It stops working and I can't view and modify anything

redwing

  • Guest
Try launching MB after moving MusicBee3Settings.ini file in AppData folder to another place temporarily.
If that works fine, your settings file might be corrupted. Then you might need to start from the new default settings file again.

zion

  • Newbie
  • *
  • Posts: 7
I did as you said, I also did a clean install but I have always the same problem.

The user wynford had the same problem https://getmusicbee.com/forum/index.php?topic=5647.15
Maybe, it solved this issue.
I think this problem is related with my pc settings

redwing

  • Guest
Then what if you try with empty Codec folder?
If that works fine, try adding codec files one by one.

zion

  • Newbie
  • *
  • Posts: 7

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33477
do you have a windows "N" machine by any chance? ("N" is the EU edition without any WMA/ MP3 codecs)

redwing

  • Guest
"N" is the EU edition without any WMA/ MP3 codecs

That explains it if that's the case. Then how about disabling WMA by default for encoding? If people want, they can always enable it.

zion

  • Newbie
  • *
  • Posts: 7
I don't have N edition. I'm on Windows 8.1 Pro x64.
I use MusicBee 3.1 portable. However I also tried 3.0 installer but I always have the same problem

redwing

  • Guest
Then did your machine come with Windows Media Player installed? And have you by any chance removed the functionality?

zion

  • Newbie
  • *
  • Posts: 7
Yes, I have Windows Media Player installed. I didn't remove any functionality. I also have installed 3 plugins: Windows Media Player Plus! 2.8, WMV Tag Plus 2.9, WMVCDText 1.4. Also I have installed Windows Media Player 64 bit Plug-in Fix (I don't remember to have installed this plugin fix)

redwing

  • Guest
I think one thing you can try is disabling WMA from the encoder setting by editing settings file. But I'm not sure this can fix the issue or further action is required.

Anyway, open MusicBee3Settings.ini file with a text editor and find
<EncoderApplicationPath />

Then two lines above it,
find "<Enabled>true</Enabled>" and change it to "<Enabled>false</Enabled>".
Save and restart MB.

If this doesn't help, then ask Steven for help.

zion

  • Newbie
  • *
  • Posts: 7

redwing

  • Guest
Then I guess it means opening file converter tab in preferences triggers MB to look for the hardcoded WMA codec even when WMA option is disabled.
I don't know what exactly happened to your machine, but those WMP plugins you've installed might have changed the original WMA codec setting or overwrote them with their own. Also I don't know whether uninstalling those plugins could resolve the issue or not. You might try looking for the official WMP codec pack for Windows 8.1 and reinstall it, or reinstalling Windows might resolve the issue. But this is just my pure guess without hearing anything from Steven.

zion

  • Newbie
  • *
  • Posts: 7
I uninstalled those plugins and nothing has changed.
I checked wmp.dll and have it twice. They are original Microsoft files
Do you know how debug MusicBee?

redwing

  • Guest