Author Topic: Keyboard Play/Pause Button Inputs twice when MusicBee is not in focus  (Read 6579 times)

eomo

  • Newbie
  • *
  • Posts: 1
As the title suggests, the keyboard Play/Pause Button inputs twice when MusicBee is not in focus, resulting in a track continuing it's play with a slight (0.5 of a second) period of fading to silence. When MusicBee is clicked on to focus the window, this behaviour does not occur. If there is no music playing, it will play a tiny amount and go back to paused

MusicBee version: 3.1.6401
Windows 10
Keyboard is a Microsoft Sidewinder X4 - unfortunately I have not been able to test with another keyboard.

Closing all other programs does not change this behaviour

Previous versions of MusicBee, this behaviour was observed with both MusicBee in and out of focus, and also occurred with the skip and previous track buttons. Updating to 3.1.6401 from 3.1.5XXX solved the other buttons and in focus behaviour

ztp

  • Newbie
  • *
  • Posts: 1
I have the same problem with the following differences:
- Happening for about a year now, even with 3.1.6466
- Always happened with MusicBee window in or out of focus
- Using a Microsoft Bluetooth keyboard (my wired keyboard does not have media keys)

On Windows 10. And problem does not show on Windows GooveMusic.

hughbiquitous

  • Newbie
  • *
  • Posts: 1
Same here... I'm using a Microsoft Natural Ergonomic Keyboard 4000.

Environment: MusicBee 3.1.6512
Windows 10 Pro (64-bit), Version 1709, Build 16299.125

Given: MusicBee is playing music (can be focused or unfocused; can be minimized, maximized, or normal)
  and: the Microsoft Mouse and Keyboard Center shows that the dedicated play/pause button is set to "Play or pause media track (default)"

When: I press the dedicated play/pause button on the keyboard

Then: (Expected) MusicBee should pause playback.
     (Actual/Observed): MusicBee pauses momentarily and immediately resumes playback.


Similarly, if MusicBee is not playing, pressing the play/pause button should start playback, but instead it plays momentarily and goes back to paused.

lestersk

  • Newbie
  • *
  • Posts: 2
The MB app is receiving the Pause or Play twice, once from the App and once from the inbuilt keyboard function.

Work Around
Until I discovered the solution below I programmed the "Pause" button to do the Pause/Play function.

Solution
The solution to the double input is simply to disable the functionality of the pause button.

Method
Press the STAR button to edit the keyboard buttons and set the Pause/Play button to "disable this key". (works on MS Dig Media 3000 keyboard)


garretwilson

  • Newbie
  • *
  • Posts: 9
I can confirm that with the Natural Ergonomic Keyboard 4000, the workaround of disabling the Play/Pause button fixes this problem. Moreover Microsoft Mouse and Keyboard Center seems to allow me to disable the key just for the MusicBee application.

But I wish this could be fixed in MusicBee itself. MediaMonkey doesn't seem to have this problem, for example. Is this a MusicBee bug?

garretwilson

  • Newbie
  • *
  • Posts: 9
Unfortunately the workaround doesn't fully work. It turns out that if I disable the play/pause key for just the MusicBee app, then play/pause works when MusicBee has the focus, but I get the double recognition (play then stop or stop then play, as described above) if another windows has the focus.

But if I disable the media play/pause key for all applications, then I can no longer use the key for other applications, such as VLC media player.

I tried going into MusicBee and setting play/pause to not be global. Then I disabled the play/pause key in the Microsoft Mouse and Keyboard Center, just for the MusicBee app. Now the same thing happens: I can use play/pause within MusicBee, but when another has the focus, I get the double-input problem.

I don't understand why MusicBee can't fix this, if other applications such as MediaMonkey don't have this problem.

ludera

  • Newbie
  • *
  • Posts: 1
I managed to fix this (Dec 2019).

Exported settings using the Edit menu. I removed MusicBee. Installed it using the Store of Windows 10 (the app is also there). Imported the settings.
Then I went to MB preferences and went to the last tab --> Plugins --> Media Control. Press Disable. If you disable this, it will not detect two plays, just the Windows' one.

Also I had to tell windows that the default app for playing music is MB too. I don't really kinow if this is needed. But you can do it in the windows preferences -> Applications --> Default apps --> for music choose MusicBee.

miousque

  • Newbie
  • *
  • Posts: 1
I find out a simple solution. Simply remove the Media Play Pause hotkey in the MB preferences. You dont even need to assign any action to the button for it to work.

chrisma

  • Newbie
  • *
  • Posts: 1
For anyone like me, for whom the posted solutions either didn't work or weren't what you want. Maybe this will be better.

I've assigned the play-pause button to start a program:
"C:\Program Files (x86)\MusicBee\MusicBee.exe" /PlayPause"

For anyone looking for a previous and next button on the microsoft keyboard, you can do what I did and assign the 4th and 5th marco key to start program:
"C:\Program Files (x86)\MusicBee\MusicBee.exe" /Previous
"C:\Program Files (x86)\MusicBee\MusicBee.exe" /Next

Although you might have to adjust the paths according to your installation. Hope this help future people with this problem and is not regarded as necromancy.

jim777

  • Newbie
  • *
  • Posts: 1
This worked. I created batch files for each of these commands, and set them in Logitech Options.