Author Topic: Library has gone  (Read 3910 times)

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
Hello,
I just seem to have lost my library.
When I open musicbee the main panel remains empty.
Playlists are still there and playable and so is the inbox. Also, files that were playing are still in the "playing tracks"-panel and playable.
I can select playlists for playing and they play but they do not display in the main panel.
The only thing I have changed is that sometimes I have a VPN-connection running which leads to an inability to access the library as it is connected through LAN and that Cisco VPN-client does not allow for LAN connections. The behaviour appeared with the 3.1.6.335 version but did not change with the update to 3.1.6388.
But above mentioned behaviour also appears with perfect access to the music library. I have tried to start both the .mbl- and the .bak-files (the latter renamed as .mbl-file) but the results were the same.
What can I do?
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
Or is it the MusicBeeLibrarySettings.ini?
I still can't get round to what is wrong...
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
Ok, so since obviously there's no way of reconstructing the library:
If I reread all files what would this mean for the playlists that still display in Musicbee? Would stats also be lost?
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3840
  • MB Version: 3.6.8878 P
I had a similar issue after a recent 3.1 update.
Hold down the shift key as MB starts and make sure it is accessing the correct library path.
MusicBee and my library - Making bee-utiful music together

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
Thanks for getting back.
In fact I can make a choice between the library in "My Music" or in "Music" but this seems to be the same path. But regardless which one I choose it always opens to a list that is empty but with the playlists intact and playable. Filters are also there...
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10718
Playlists and filters are both stored separately from the library file.  It may be too late at this point, but have you looked for a .bak version of the library file?
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest patches (3.5/3.6)
(Unzip and overwrite existing program files)

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
Thing is I think I have one but I do not know which state of the database this file does reflect. I have made a copy of all the settings files as soon as I had realised that sth was wrong but it might have been too late.
How would I restore from a .bak-file?
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10718
Just rename it to .ini.

Yeah, my concern is that it would have been created since the problem happened, in which case it does you no good.  But worth a try.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest patches (3.5/3.6)
(Unzip and overwrite existing program files)

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
I think I will just have to delete the library and start afresh... here we go.
Thanks for advice anyway!
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
OK, so I have a new library and everything worked fine as it is usual with Musicbee.
But I have the following questions:
1. I have a file called MusicBeeLibrary.lyrics both in the old and the new folder. In the old version it is 44mb in the new version it is 22mb. Obviously it contains loads of lyrics. What is this file for? I have all lyrics saved in tags...
2. Also the new MusicBeeLibrary.mbl is 9mb while the old one is 22mb. How can I account for this difference?
3. I also have a file called mb_LyricsReloaded.log in a folder of the same name and it is 39mb. What is it for?
4. There is not the slightest possibility to extract playcounts from the old database? Or maybe just to write the last.fm count into the playcount?
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage

so_la_la

  • Sr. Member
  • ****
  • Posts: 301
4. There is not the slightest possibility to extract playcounts from the old database? Or maybe just to write the last.fm count into the playcount?

I have seen that this is possible. This is great!

(Just out of curiosity: will it ADD Last.fm's playcount to library values or will it REPLACE them? (I have two last.fm accounts don't ask why and this might be a way to unite them))
Music Bee 3; EAC; MP3Tag; Music on Synology NAS 115; Logitech Media Server on RPI 3; RPI 2 with Hifiberry; Poweramp for Android/Lineage