Author Topic: Multimedia Keys not working.  (Read 4830 times)

krissasaur

  • Jr. Member
  • **
  • Posts: 77
I have searched the forum and I found other topics, but nothing answered the question. (The topics I found said to search the forum because it has been asked before.) I hope someone can give me an answer.

Basically, the media keys on my keyboard and the ones I set on my mouse (Through Razer Synapse, so it's an actual media key.) are not working with Musicbee, where in the past, they worked fine.

Does anyone have any idea why?

CritterMan

  • Sr. Member
  • ****
  • Posts: 556
  • Now with FiiO M11!
I've got Razer hardware on my home rig running Win7 and on my work rig at the office running Win10. All media keys working great with MB on both machines. You've either got a problem with Synapse or some other application running on your computer is intercepting the inputs before they get to MB.

1) Test the media keys with another application, such as VLC media player. If they won't work with another player, you've got a Razer issue.

2) Check for any other applications running in the background that play sound or video. Close them. If that fixes the issue, one of the applications you closed is causing the problem.

If the above tests aren't conclusive. Describe how you performed the tests and we'll see what else you can try.
Home Desk ~ MB 3.3 Portable • Questyle CMA400i (ASIO) • Sennheiser HD 660S (balanced) / Audeze EL-8 Closed Back / Fostex TR-X00 Ebony • Teac AI-101DA • Jamo C93 + Dayton Audio SUB-1000
Work Desk ~ MB 3.3 Portable / Tidal • SMSL SU-8 v2 • Nobsound NS-05P • THX AAA 789 • Sennheiser HD 58X (balanced)
OTG ~ FiiO M11 • Audiofly AF180 / B&O H6

krissasaur

  • Jr. Member
  • **
  • Posts: 77
I've got Razer hardware on my home rig running Win7 and on my work rig at the office running Win10. All media keys working great with MB on both machines. You've either got a problem with Synapse or some other application running on your computer is intercepting the inputs before they get to MB.

1) Test the media keys with another application, such as VLC media player. If they won't work with another player, you've got a Razer issue.

2) Check for any other applications running in the background that play sound or video. Close them. If that fixes the issue, one of the applications you closed is causing the problem.

If the above tests aren't conclusive. Describe how you performed the tests and we'll see what else you can try.

I should have clarified that I also have a Logitech G610 keyboard with media keys that stopped working as well, so I don't believe it is the Synapse software, I just pointed that out because it allows you to make legit media keys on the mouse.

I don't have any other software open that uses the media keys. I actually don't have any other programs to test the keys with.. let me think... Wait does Spotify...? I have that...

Okay.... this is... weird. The media keys started to work for MusicBee when I opened Spotify. When I close Spotify, they stop working. They also wouldn't control Spotify, only MusicBee. I am beyond confused now.


Also more information I left out, I have Windows 10 Pro. I am on the most recent creative update, or whatever it is called.


phred

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 9344
Also more information I left out, I have Windows 10 Pro. I am on the most recent creative update, or whatever it is called.
Windows 10 'Creators Update' has been shown to cause a good number of problems for media devices. Not sure that your keyboard would be considered a media device, but since it -controls- media, perhaps.

I'd roll Win10 back to Anniversary if you can. And if it works, then do whatever you can to prevent Creators from being reinstalled. I know MicroSoft doesn't make this easy.
Download the latest MusicBee v3.5 or 3.6 patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
The FAQ
The Wiki
Posting screenshots is here
Searching the forum with Google is  here