Author Topic: Organize library files  (Read 2855 times)

lordlance

  • Jr. Member
  • **
  • Posts: 22
I updated musicbee to v.3 (also patched with the latest zip version today).
Usually I keep my library and my music folder (auto organized by musicbee) in my NAS on my network. Until v2.5xxx I had no problem.
Now, if I go in Preferences > Library [v] Auto-organize media files > Organization
I see:
move: Music on drive: \\NASQNAP\ to folder: \\NASQNAP\Multimedia\musica\
The informations here are correct. If I click on [...] and I reselect the folder from the selection menu, I find no problems, I can browse the folder, then I click [Select], I get an error windows that says "Drive or network share '\\NASQNAP\' does not exist.

This is quite strange, I never got that error before.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34258
i see no incorrect behavior. MB is validating the second input field "on drive:"
usually you need to specify a share folder name so the value should probably be:
\\NASQNAP\Multimedia

lordlance

  • Jr. Member
  • **
  • Posts: 22
First of all, thanks Steven for the reply.
Now, regarding the problem, the weird thing is that the software still seems working (ie. I can play the songs, clicking on them, so it seems the software CAN read the address).
BUT if I go in the preferences, and I try to (re)select the folder, I get that error.
PS: after your reply I tried to put \\NASQNAP\Multimedia as "on drive:" but the error is still the same. I feel real fear if I'll need to change that folder, in the future... :-/

lordlance

  • Jr. Member
  • **
  • Posts: 22
Steven, I did some test in these days. I'm trying to tamper with the options, to better understand what is going on.
I found part of the problem (and now I understand it's not a problem, maybe): when I'm in ORGANIZE LIBRARY FILES, I find a couple of rows, one with MUSIC, one with AUDIOBOOKS. Well, I have no audiobooks in my collection, so that row is unchecked. BUT when I start the process, for example if I changed the Naming Template in the Music row, and I hit the PROCEED button, the software STILL CHECK THE LOCATIONS THAT FIND in the other unchecked rows (in my case, audiobook), and return me an error because in that row probably I had a wrong/old path.
This is annoying, also I can't remove useless rows "in excess".
Last Edit: May 28, 2016, 10:16:53 AM by lordlance

kricker

  • Jr. Member
  • **
  • Posts: 30
I just upgraded to 3.0.5995 yesterday and I ran across this issue with a network drive as well. I store all my music at \\TOWER\Music. Musicbee stills sees the files and plays them fine. It is the Organization window that is having issues. It appears the "on drive:" value was set to just \\TOWER\ instead of \\TOWER\Music. Once I changed that it worked fine. Odd it was set that way as things worked fine before the upgrade.

BTW, I LOVE MusicBee! Thanks.