Author Topic: Musicbee stops playing when windows 10 turns off screen for energy saving  (Read 7205 times)

silvandy

  • Newbie
  • *
  • Posts: 9
I have an HP detachable notebook with windows 10. Energy saving settings make the screen turn off after 5 minutes of inactivity when you're running on batteries. Unfortunately, if musicbee is playing at that time, it stops together with the screen, and resumes only when the user revives the screen with some activity.

While of course you could fully disable the energy saving feature to avoid the problem, this is actually counterproductive: if you want to play music for a long time when running on batteries, what you need is exactly to turn off the screen and use energy only for playback!

I could not find an option to avoid this problem in musicbee settings; nor did I find any hint to help looking in the forums or anywhere else on the web.

Notice that win10 own music app, the so called "Music groove", does NOT have this problem: in the same situation described above music will go on playing without interruptions.

Any help would be appreciated, thanks

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 29975
I am not sure why you think this is a bug. I will move this to the wishlist. However i dont think it can be supported for windows desktop applications ("Groove" is a universal windows application which is something new)

silvandy

  • Newbie
  • *
  • Posts: 9
Thank you for the swift reaction!!
In windows 7 this problem does not occur, so I was rather disappointed to have it in windows 10. It is actually microsoft's "fault", since windows changed and musicbee did not (I am trying the same version on the two operating systems).
I did not really ponder what was the most appropriate list; maybe you're right in considering it a wish and not a bug; still, this is a real pain in the ass, and actually makes musicbee (or any other player, since I suppose it is not the only one displaying such behaviour) scarcely usable whenever you're using your pc just to play music, so that the screen is expected to turn off soon and stay that way for most of the time.
And I must say that your skepticism about a chance to solve this really scares me, since in the future of course all PCs will tend to have win10!
You are really saying that there is nothing to be done?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 29975
keep an eye on this topic. Probably in a couple of weeks i will try something but will need you to test it out

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3061
This doesn't happen with my desktop and laptop computers.
It is probably some specific setting, possibly HP specific.

You might try selecting a less aggressive power plan and see if that solves it.

silvandy

  • Newbie
  • *
  • Posts: 9
I would have suspected something like that if there was an hp utility to manage energy settings, but it actually is the standard "PC settings" win10 interface that affects this.
In the pc settings screen, "system" group, power options tab (see for example http://img.wonderhowto.com/img/original/00/31/63575955478586/0/635759554785860031.jpg), the first item at the top rules on this: "SCREEN - on battery power turn off after XXX minutes".
If I change this value, when inactive the screen turn off after the specified time... and musicbee will mute accordingly. As soon as I move the mouse and the screen is back on, musicbee will resume playback.
Some news: I fiddled with this settings a little bit, discovering that the behaviour does NOT depend on electricity coming from batteries or the power line: I experienced it with battery power since the screen timeout was shorter, but it happens when plugged as well if the "plugged in" screen timeout is reached.

In this situation, I do not really know what kind of "less aggressive" power settings I could use, else than setting screen timeout to very long times both when on batteries as well as when plugged in. If you have any specifc hint on this please let me know!

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3061
If you do a Windows search for 'power plan' that should bring you to more advanced settings where you can select pre-configured plans (probably one from HP is currently selected), and you can also edit those plans yourself.


psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8505
This happens to me on a Dell, too, so it's not just hp.  I look forward to trying out the solution.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.3)
(Unzip and overwrite existing program files)

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3061
It doesn't happen on my Dell. (clean installed without any Dell stuff though)

Changing powerplans doesn't work for you either?
It must have something to do with a setting that puts the soundcard to sleep.
It might also be a registry setting, or something in the audio driver. That won't make it easy to find and fix by yourself.
Are you using the internal speakers, or external ones?


Skoop

  • Sr. Member
  • ****
  • Posts: 269
The same thing will happen with speakers that are embedded into a monitor.  Monitor off, speakers off. 

Your notebook appears to be acting in the same way; perhaps the monitor and speakers are an integral unit.

Anyway, in your power settings, change it to never turn off the monitor.  If you want the power savings, though, set a screensaver in display properties to blank screen.  It will look the same (black), but the monitor will not be switched off.

boroda

  • Hero Member
  • *****
  • Posts: 3374
if its not amoled monitor, then nothing will give power saving using blank screen screensaver.

silvandy

  • Newbie
  • *
  • Posts: 9
I have tried the patched exe proposed, but the behaviour does not change: alas, when the screen turn off, so does playback....

Going back to hiccup post suggesting to use the older interface control panel instead that metro-inteface PC settings, I have explored the thing and i must say that I found the two interfaces to be closely related in terms of saving user preferences: in the old cntrol panel I have one power plan only (the so called "balanced") and it has the same and only the same options that you get in the pc settings interface. Moreover you change and save new settings in one interface, you get the new value in the other as well. They appear to be completely consistent (it is actually absurd to have two fully different interfaces to do the same thing, but this is not the matter now). so I found this change of perspective to be of no help, you have the same settings and they act the same way. Thanks anyway

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 3061
Windows comes with a couple of power plans by default.
And also other manufacturers (HP, Dell, manufacturers of graphics, harddisks etc.) can add them.
If you can only see one power plan, you either have a customized Windows installation, or you don't have full user access for that computer.
Is it perhaps a laptop 'from work'?

silvandy

  • Newbie
  • *
  • Posts: 9
It is a machine I use for work as well, but i have an account with administrator privileges. In the control panel there are no other power plans except the "balanced" one, which actually appears to be active. When editing its settings, it has exactly the same option than the PC settings with metro interface: screen and cpu disable timeouts with batteries and power line. And the options values are just the same, and stay the same in the two environments if you change them.
Keep in mind that I know what you mean, i.e. that with control panel you can create and alternatively activate different energy profiles. This machine (which is a small HP 10 inches detachable X2 210 g1) apparently ha no HP-made preinstalled energy profile, just the balanced one